meta-agl-core: dynamically add qtbase bbappend 95/26395/3
authorScott Murray <scott.murray@konsulko.com>
Mon, 7 Jun 2021 21:29:36 +0000 (17:29 -0400)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 8 Jun 2021 21:55:19 +0000 (21:55 +0000)
Add a dynamic layer addition for meta-qt5 that contains a qtbase
bbappend with the required configuration changes for building
it with Wayland support.  The aim is to avoid duplication of these
configuration changes among meta-agl-core users.

Bug-AGL: SPEC-3972

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: I642ad6e62c10da1b1c2323a13c7d5fa91ba9f028
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/26395
Tested-by: Jenkins Job builder account
ci-image-build: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-agl-core/conf/layer.conf
meta-agl-core/dynamic-layers/meta-qt5/recipes-qt/qt5/qtbase_%.bbappend [new file with mode: 0644]
meta-agl-core/dynamic-layers/meta-qt5/recipes-qt/qt5/qtbase_aglcore.inc [new file with mode: 0644]

index 2218e3d..efbf6e6 100644 (file)
@@ -9,6 +9,11 @@ BBFILE_COLLECTIONS += "aglcore"
 BBFILE_PATTERN_aglcore = "^${LAYERDIR}/"
 BBFILE_PRIORITY_aglcore = "60"
 
+BBFILES_DYNAMIC += " \
+    qt5-layer:${LAYERDIR}/dynamic-layers/meta-qt5/*/*/*.bb \
+    qt5-layer:${LAYERDIR}/dynamic-layers/meta-qt5/*/*/*.bbappend \
+"
+
 LAYERSERIES_COMPAT_aglcore = "dunfell"
 LAYERDEPENDS_aglcore = "core"
 
diff --git a/meta-agl-core/dynamic-layers/meta-qt5/recipes-qt/qt5/qtbase_%.bbappend b/meta-agl-core/dynamic-layers/meta-qt5/recipes-qt/qt5/qtbase_%.bbappend
new file mode 100644 (file)
index 0000000..aab944c
--- /dev/null
@@ -0,0 +1 @@
+require ${@bb.utils.contains('AGL_FEATURES', 'aglcore', 'qtbase_aglcore.inc', '', d)}
diff --git a/meta-agl-core/dynamic-layers/meta-qt5/recipes-qt/qt5/qtbase_aglcore.inc b/meta-agl-core/dynamic-layers/meta-qt5/recipes-qt/qt5/qtbase_aglcore.inc
new file mode 100644 (file)
index 0000000..ae5444e
--- /dev/null
@@ -0,0 +1,8 @@
+PACKAGECONFIG_WAYLAND = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)}"
+
+PACKAGECONFIG_GL = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2', '', d)}"
+
+PACKAGECONFIG_append = " ${PACKAGECONFIG_WAYLAND}"
+
+# '-qpa wayland-egl' set wayland-egl as default of platform plugins
+PACKAGECONFIG[wayland]="-qpa wayland-egl -no-qpa-platform-guard"