weston-ini-conf: make remote output configuration dynamic 15/28415/3
authorScott Murray <scott.murray@konsulko.com>
Mon, 16 Jan 2023 22:04:08 +0000 (17:04 -0500)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Sun, 29 Jan 2023 14:30:03 +0000 (14:30 +0000)
Rework things to also update the remote output configuration
fragment based on the value of TRANSMITTER_OUTPUT_HOST.  This
helps when using different IP addresses for e.g. the KVM demo
configuration.

Bug-AGL: SPEC-4618

Change-Id: I198ff3e6a30b3968b4749998354a39325c088933
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
(cherry picked from commit 39def8ebd98c98e67304517ab118f9bde4cdf8e7)
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/28415
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb
meta-agl-core/recipes-graphics/wayland/weston-ini-conf/remote-output.cfg.in [moved from meta-agl-core/recipes-graphics/wayland/weston-ini-conf/remote-output.cfg with 100% similarity]

index 50e5134..ae5eb55 100644 (file)
@@ -9,7 +9,7 @@ SRC_URI = " \
        file://hdmi-a-1-90.cfg \
        file://hdmi-a-1-180.cfg \
        file://hdmi-a-1-270.cfg \
-       file://remote-output.cfg \
+       file://remote-output.cfg.in \
        file://transmitter-output.cfg.in \
        file://virtual-0.cfg \
        file://virtual-90.cfg \
@@ -43,6 +43,9 @@ do_configure() {
         -e "s#host=.*#host=${TRANSMITTER_OUTPUT_HOST}#" \
         -e "s#port=.*#port=${TRANSMITTER_OUTPUT_PORT}#" \
         ${WORKDIR}/transmitter-output.cfg.in  > ${WORKDIR}/transmitter-output.cfg
+    sed -e "s#host=.*#host=${TRANSMITTER_OUTPUT_HOST}#" \
+        -e "s#port=.*#port=${TRANSMITTER_OUTPUT_PORT}#" \
+        ${WORKDIR}/remote-output.cfg.in  > ${WORKDIR}/remote-output.cfg
 }
 
 do_compile() {
@@ -62,6 +65,7 @@ do_compile() {
     # and a corresponding landscape-inverted that is 180 degrees
     # rotated.
     rm -f ${WORKDIR}/weston.ini.landscape
+    rm -f ${WORKDIR}/weston.ini.landscape-inverted
     for F in ${WESTON_FRAGMENTS}; do
         INVF=$F
         if echo $F | grep '^hdmi-a-1-\(90\|270\)$'; then