Add AGL machine template for s32g274ardb2 aka goldbox 98/27498/2
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Thu, 19 May 2022 15:22:34 +0000 (17:22 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 24 May 2022 11:03:49 +0000 (11:03 +0000)
This adds the machine template and tweaks to build an image
that matches the s32g274ardb2 aka 'goldbox' .

Bug-AGL: SPEC-4387
Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Change-Id: I90cb5d109d4327147025fa81a70ef0c9adb0c78f
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/27498
Tested-by: Jenkins Job builder account
ci-image-build: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account

meta-agl-bsp/conf/include/agl_s32g274ardb2.inc [new file with mode: 0644]
meta-agl-bsp/meta-alb/recipes-bsp/u-boot/u-boot-s32_%.bbappend [new file with mode: 0644]
meta-agl-bsp/meta-alb/recipes-kernel/linux/linux-s32_5.%.bbappend [new file with mode: 0644]
templates/machine/s32g274ardb2/40_bblayers.conf.inc [new file with mode: 0644]
templates/machine/s32g274ardb2/50_local.conf.inc [new file with mode: 0644]
templates/machine/s32g274ardb2/50_setup.sh [new file with mode: 0644]
templates/machine/s32g274ardb2/README_machine_s32g274ardb2.md [new file with mode: 0644]

diff --git a/meta-agl-bsp/conf/include/agl_s32g274ardb2.inc b/meta-agl-bsp/conf/include/agl_s32g274ardb2.inc
new file mode 100644 (file)
index 0000000..bd455f4
--- /dev/null
@@ -0,0 +1,29 @@
+# Disable meta-freescale package architecure mangling, as it causes
+# issues with AGL's explicit setting of DEFAULTTUNE.
+INHERIT:remove = "fsl-dynamic-packagearch"
+MACHINE_SOCARCH = "${TUNE_PKGARCH}"
+
+# Disable the meta-freescale weston-init bbappend as it conflicts
+# with AGL's.
+BBMASK:append = " meta-freescale/recipes-graphics/wayland/weston-init"
+
+# do not replace or append YP core recipes at all
+BBMASK:append = " meta-alb/dynamic-layers/core/"
+
+# Avoid needing meta-python2
+BBMASK:append = " meta-alb/dynamic-layers/freescale-layer/recipes-extended/vpp-core/vpp-core.bb"
+BBMASK:append = " meta-alb/recipes-(connectivity|core|devtools|extended/xen|support/rng-tools)/"
+
+# Seems like it might be worthwhile to get dunfell version, but doesn't work?:
+#BBMASK:append = " meta-alb/recipes-bsp/u-boot/u-boot.inc"
+
+PREFERRED_VERSION_rng-tools ?= "6%"
+
+# export?
+RELEASE_BASE = "release/bsp32.0"
+
+# the label needs to be shorter than we would expand to by default !!
+# Defaults to boot-${MACHINE}  which happens to be more than 11 chars
+BOOTDD_VOLUME_ID = "boots32g"
+
+AGL_DEFAULT_IMAGE_FSTYPES ?= "sdcard ext4 tar.xz"
\ No newline at end of file
diff --git a/meta-agl-bsp/meta-alb/recipes-bsp/u-boot/u-boot-s32_%.bbappend b/meta-agl-bsp/meta-alb/recipes-bsp/u-boot/u-boot-s32_%.bbappend
new file mode 100644 (file)
index 0000000..465023c
--- /dev/null
@@ -0,0 +1,5 @@
+# Missing from the meta-alb u-boot.inc
+inherit python3native
+
+DEPENDS:remove = "python-native"
+DEPENDS:append = " python3-native"
diff --git a/meta-agl-bsp/meta-alb/recipes-kernel/linux/linux-s32_5.%.bbappend b/meta-agl-bsp/meta-alb/recipes-kernel/linux/linux-s32_5.%.bbappend
new file mode 100644 (file)
index 0000000..787ead1
--- /dev/null
@@ -0,0 +1 @@
+addtask merge_delta_config before do_kernel_localversion
\ No newline at end of file
diff --git a/templates/machine/s32g274ardb2/40_bblayers.conf.inc b/templates/machine/s32g274ardb2/40_bblayers.conf.inc
new file mode 100644 (file)
index 0000000..c668d27
--- /dev/null
@@ -0,0 +1,8 @@
+# This must be parsed after qt5, etc. layers so that they are correctly
+# recognized by meta-freescale/dynamic-layers
+BBLAYERS =+ "\
+  ${METADIR}/bsp/meta-freescale \
+  ${METADIR}/bsp/meta-alb \
+  ${METADIR}/bsp/meta-linaro/meta-optee \
+  ${METADIR}/external/meta-python2 \
+  "
diff --git a/templates/machine/s32g274ardb2/50_local.conf.inc b/templates/machine/s32g274ardb2/50_local.conf.inc
new file mode 100644 (file)
index 0000000..3e15d4c
--- /dev/null
@@ -0,0 +1,3 @@
+MACHINE = "s32g274ardb2"
+#see meta-agl/meta-agl-bsp/conf/include/agl_s32g233aevb.inc
+require conf/include/agl_s32g274ardb2.inc
diff --git a/templates/machine/s32g274ardb2/50_setup.sh b/templates/machine/s32g274ardb2/50_setup.sh
new file mode 100644 (file)
index 0000000..eefd1eb
--- /dev/null
@@ -0,0 +1,2 @@
+find_and_ack_eula $METADIR/bsp/meta-freescale EULA
+export EULA_FLAG_NAME="ACCEPT_FSL_EULA"
diff --git a/templates/machine/s32g274ardb2/README_machine_s32g274ardb2.md b/templates/machine/s32g274ardb2/README_machine_s32g274ardb2.md
new file mode 100644 (file)
index 0000000..59d8062
--- /dev/null
@@ -0,0 +1,6 @@
+---
+description: S32G
+authors: Scott Murray <scott.murray@konsulko.com>
+---
+
+### Machine s32g274ardb2