wayland/weston-ini-conf: Add transmitter-output ini section 54/25454/14
authorMarius Vlad <marius.vlad@collabora.com>
Fri, 16 Oct 2020 14:37:35 +0000 (17:37 +0300)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Fri, 22 Jan 2021 14:54:00 +0000 (14:54 +0000)
And with it, build remoting plug-in when weston-waltham-remoting AGL
feature is set.

agl-compositor will use the remoting plug-in to create a remote output
so we need the remoting plug-in built as well as weston-remoting distro
feature.

v8 (mvlad): plain rebase to new folder structure, use AGL_FEATURES
instead of DISTRO_FEATURES
v7 (mvlad): plain rebase to new folder structure
v6 (jsmoeller): plain rebase to new folder structure

Bug-AGL: SPEC-3601

Signed-off-by: Marius Vlad <marius.vlad@collabora.com>
Change-Id: Idf591e3f6954bdaafe917e5ceb93fde134dde8db
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25454
Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bbappend
meta-agl-core/recipes-graphics/wayland/weston-ini-conf/transmitter-output.cfg [new file with mode: 0644]
meta-agl-core/recipes-graphics/wayland/weston_8.0_aglcore.inc

index 0f51d59..88590c6 100644 (file)
@@ -3,6 +3,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
 WESTON_DISPLAYS_append = "${@bb.utils.contains("DISTRO_FEATURES", "weston-remoting", " remote-output", "", d)}"
+WESTON_DISPLAYS_append = "${@bb.utils.contains("AGL_FEATURES", "waltham-remoting", " transmitter-output", "", d)}"
 
 # For virtual machines and intel-corei7-64 we want to support both the HDMI-A-1
 # and Virtual-1 outputs. This allows us to run virtual images on real hardware
diff --git a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/transmitter-output.cfg b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/transmitter-output.cfg
new file mode 100644 (file)
index 0000000..e77f74e
--- /dev/null
@@ -0,0 +1,5 @@
+[transmitter-output]
+name=transmitter-1
+mode=640x720@30
+host=192.168.20.99
+port=5005
index c249546..ec4165c 100644 (file)
@@ -9,3 +9,4 @@ SRC_URI_append = "\
 # Workaround for incorrect upstream definition
 PACKAGECONFIG[remoting] = "-Dremoting=true,-Dremoting=false,gstreamer1.0 gstreamer1.0-plugins-base"
 PACKAGECONFIG_append = "${@bb.utils.contains('DISTRO_FEATURES', 'weston-remoting', ' remoting', '', d)}"
+PACKAGECONFIG_append = "${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', ' remoting', '', d)}"