weston: Launch even without input devices 03/11203/2
authorLeon Anavi <leon.anavi@konsulko.com>
Tue, 10 Oct 2017 14:32:57 +0000 (17:32 +0300)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 11 Oct 2017 09:11:26 +0000 (09:11 +0000)
Fix the recurring bug and launch Weston 2.0 even
if there are no input devices such a keyboard
or a mouse.

Bug-AGL: SPEC-936

Change-Id: I9c92ce7762626fd5df40224b53317c1239a4bd6f
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/11203
Reviewed-by: Thomas Rini <trini@konsulko.com>
Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
Reviewed-by: Changhyeok Bae <changhyeok.bae@gmail.com>
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-agl/recipes-graphics/wayland/weston/0001-compositor-drm.c-Launch-without-input-devices.patch [new file with mode: 0644]
meta-agl/recipes-graphics/wayland/weston_2.0.0.bbappend

diff --git a/meta-agl/recipes-graphics/wayland/weston/0001-compositor-drm.c-Launch-without-input-devices.patch b/meta-agl/recipes-graphics/wayland/weston/0001-compositor-drm.c-Launch-without-input-devices.patch
new file mode 100644 (file)
index 0000000..6b47b5e
--- /dev/null
@@ -0,0 +1,27 @@
+From 9da4f513547b4a4f0972cc718b55ba3fc5271c87 Mon Sep 17 00:00:00 2001
+From: Leon Anavi <leon.anavi@konsulko.com>
+Date: Tue, 10 Oct 2017 17:21:09 +0300
+Subject: [PATCH] compositor-drm.c: Launch without input devices
+
+Launch Weston 2.0 even if there are no input devices.
+
+Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
+---
+ libweston/compositor-drm.c | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/libweston/compositor-drm.c b/libweston/compositor-drm.c
+index 1d38f05..afe0dea 100644
+--- a/libweston/compositor-drm.c
++++ b/libweston/compositor-drm.c
+@@ -3278,7 +3278,6 @@ drm_backend_create(struct weston_compositor *compositor,
+                           compositor, b->udev, seat_id,
+                           config->configure_device) < 0) {
+               weston_log("failed to create input devices\n");
+-              goto err_sprite;
+       }
+       b->connector = config->connector;
+-- 
+2.7.4
+
index 65f34bc..32df379 100644 (file)
@@ -2,6 +2,7 @@ FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
 
 SRC_URI_append = "\
     file://0001-Allow-regular-users-to-launch-Weston_2.0.0.patch \
+    file://0001-compositor-drm.c-Launch-without-input-devices.patch \
     "
 
 EXTRA_OECONF_append = " --enable-sys-uid"