meta-agl-netboot: increase IMAGE_ROOTFS_EXTRA_SPACE 79/9779/2
authorStephane Desneux <stephane.desneux@iot.bzh>
Tue, 20 Jun 2017 15:07:53 +0000 (17:07 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Fri, 23 Jun 2017 11:16:47 +0000 (11:16 +0000)
More room is needed when installing debug packages or
big components like Chromium.

Also, IMAGE_ROOTFS_EXTRA_SPACE was overridden by another unidentified
configuration file or recipe: the setting is now forced. Consequently,
the extra space must be reduced specifically for initrd.

Change-Id: Id9b7659197c0840c04bce048a7bb1d96c77f3cc9
Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/9779
Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-netboot/conf/include/agl-netboot.inc
meta-netboot/recipes-core/images/initramfs-netboot-image.bb

index 47f0c08..fcff8c3 100644 (file)
@@ -1,5 +1,5 @@
 INHERIT += "netboot"
 OVERRIDES .= ":netboot"
 
-# add 256MB of extra space in ext4 output image
-IMAGE_ROOTFS_EXTRA_SPACE ?= "262144"
+# add 512MB of extra space in ext4 output image
+IMAGE_ROOTFS_EXTRA_SPACE = "524288"
index 8b461e5..b9c8d2f 100644 (file)
@@ -15,5 +15,6 @@ IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
 inherit core-image
 
 IMAGE_ROOTFS_SIZE = "8192"
+IMAGE_ROOTFS_EXTRA_SPACE = "256"
 
 BAD_RECOMMENDATIONS += "busybox-syslog"