meta-agl-profile-core: Add dev-mapping-ci recipe 08/25908/2
authorScott Murray <scott.murray@konsulko.com>
Wed, 13 Jan 2021 22:54:12 +0000 (17:54 -0500)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Thu, 14 Jan 2021 16:35:52 +0000 (16:35 +0000)
Add a dev-mapping-ci recipe that installs a CI specific version of
/etc/dev-mapping.conf for the agl-service-can-low-level binding.
Additionally, the now required "j1939" bus mapping has been added
to the default dev-mapping recipe's conf file.

To enable use of the new recipe, the definition of the variable
PREFERRED_RPROVIDER_virtual/low-can-dev-mapping has been updated in
poky-agl.conf to enables it based on the AGLCI DISTRO_FEATURE.

Bug-AGL: SPEC-3756

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: Ia980ed5e556bad9097ca0c305d1e26b21b10a9ac
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25908
Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-agl-distro/conf/distro/poky-agl.conf
meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping-ci/dev-mapping.conf.ci [new file with mode: 0644]
meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping-ci_1.0.bb [new file with mode: 0644]
meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping/dev-mapping.conf.default

index f6dc00d..e418f4c 100644 (file)
@@ -189,7 +189,7 @@ do_package_write_rpm[vardepsexclude] += "ARCHIVER_TOPDIR PF"
 PREFERRED_RPROVIDER_virtual/navigation ?= "ondemandnavi"
 
 # Set preferred provider for low-can device mapping configuration
-PREFERRED_RPROVIDER_virtual/low-can-dev-mapping ?= "dev-mapping"
+PREFERRED_RPROVIDER_virtual/low-can-dev-mapping ?= "${@bb.utils.contains('DISTRO_FEATURES', 'AGLCI', 'dev-mapping-ci', 'dev-mapping', d)}"
 
 # Mask upstream meta-security bbappend that interferes with non-linux-yocto
 # kernels due to the bug of having two wildcards, which bitbake does not
diff --git a/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping-ci/dev-mapping.conf.ci b/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping-ci/dev-mapping.conf.ci
new file mode 100644 (file)
index 0000000..bd5c213
--- /dev/null
@@ -0,0 +1,7 @@
+; Default CAN device mapping
+; Format has to follow ini rules key="value", notice " around value.
+
+[CANbus-mapping]
+hs="vcan0"
+ls="vcan0"
+j1939="vcan0"
diff --git a/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping-ci_1.0.bb b/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping-ci_1.0.bb
new file mode 100644 (file)
index 0000000..cbba573
--- /dev/null
@@ -0,0 +1,18 @@
+SUMMARY = "AGL demo device mapping configuration file"
+DESCRIPTION = "This provides a default dev-mapping.conf file \
+ that defines mapping between kernel device and logical name \
+ used in the low-can binding for the AGL CI setup."
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI += "file://dev-mapping.conf.ci"
+
+inherit allarch
+
+do_install() {
+    install -d ${D}${sysconfdir}
+    install -m 0644 ${WORKDIR}/dev-mapping.conf.ci ${D}${sysconfdir}/dev-mapping.conf
+}
+
+RPROVIDES_${PN} = "virtual/low-can-dev-mapping"