[agl-shell-activator] Decouple due to dependency on grpc 13/28513/4
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Fri, 17 Feb 2023 22:08:04 +0000 (23:08 +0100)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Mon, 27 Feb 2023 11:02:42 +0000 (11:02 +0000)
We also need to deal with DEPENDS and agl-shell-activator. The latter
is a pure grpc implementation, thus move it to a dynamic layer.

Bug-AGL: SPEC-4707

Change-Id: I308104b59333f69dfe416bd3721b11fb7e1b96c4
Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/28513
Reviewed-by: Denys Dmytriyenko <denys@konsulko.com>
Reviewed-by: Marius Vlad <marius.vlad@collabora.com>
Tested-by: Jenkins Job builder account
ci-image-build: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account

meta-agl-core/dynamic-layers/meta-oe/recipes-graphics/wayland/agl-shell-activator_git.bb [moved from meta-agl-core/recipes-graphics/wayland/agl-shell-activator_git.bb with 100% similarity]
meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb

index ea0410a..a76da66 100644 (file)
@@ -8,7 +8,7 @@ SECTION = "x11"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://COPYING;md5=fac6abe0003c4d142ff8fa1f18316df0"
 
-DEPENDS = "wayland wayland-protocols wayland-native weston grpc grpc-native \
+DEPENDS = "wayland wayland-protocols wayland-native weston \
           ${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'waltham waltham-transmitter-plugin', '', d)}"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/agl-compositor.git;protocol=https;branch=${AGL_BRANCH}"
@@ -22,15 +22,20 @@ S = "${WORKDIR}/git"
 PACKAGECONFIG ?= ""
 PACKAGECONFIG[policy-rba] = "-Dpolicy-default=rba,,librba,librba rba-config"
 PACKAGECONFIG[policy-deny-all] = "-Dpolicy-default=deny-all,,"
-PACKAGECONFIG[grpc-proxy] = "-Dgrpc-proxy=true,-Dgrpc-proxy=false"
+PACKAGECONFIG[grpc-proxy] = "-Dgrpc-proxy=true,-Dgrpc-proxy=false,grpc grpc-native,grpc agl-shell-grpc-server"
 
 inherit meson pkgconfig python3native
 
+PACKAGES =+ "agl-shell-grpc-server"
+
 FILES:${PN} = " \
     ${bindir}/agl-compositor \
     ${bindir}/agl-screenshooter \
     ${libdir}/agl-compositor/libexec_compositor.so.0 \
     ${libdir}/agl-compositor/libexec_compositor.so.0.0.0 \
+"
+
+FILES:agl-shell-grpc-server = " \
     ${libdir}/agl-compositor/agl-shell-grpc-server \
 "