meta-app-framework: applaunchd: update for gRPC addition 84/27984/4
authorScott Murray <scott.murray@konsulko.com>
Sat, 10 Sep 2022 17:07:20 +0000 (13:07 -0400)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 21 Sep 2022 13:18:34 +0000 (13:18 +0000)
Changes to facilitate building gRPC enabled versionm of applaunchd:
- Bump SRCREV to pick up gRPC changes
- Add required protobuf and gRPC dependencies to DEPENDS
- Add new systemd unit for standalone gRPC API daemon

Bug-AGL: SPEC-4559

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: I21778f27b2eabd952e983b4571de05ad5d6c5af2
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/27984
Tested-by: Jenkins Job builder account
ci-image-build: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-app-framework/recipes-core/applaunchd/applaunchd/applaunchd.service [new file with mode: 0644]
meta-app-framework/recipes-core/applaunchd/applaunchd_git.bb

diff --git a/meta-app-framework/recipes-core/applaunchd/applaunchd/applaunchd.service b/meta-app-framework/recipes-core/applaunchd/applaunchd/applaunchd.service
new file mode 100644 (file)
index 0000000..95673e9
--- /dev/null
@@ -0,0 +1,12 @@
+[Unit]
+Wants=network.target
+After=network.target
+
+[Service]
+User=agl-driver
+Environment=XDG_DATA_DIRS=/usr/share
+ExecStart=/usr/bin/applaunchd
+Restart=on-failure
+
+[Install]
+WantedBy=multi-user.target
index e6439c3..d717141 100644 (file)
@@ -8,6 +8,9 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 DEPENDS = " \
     glib-2.0 \
     glib-2.0-native \
+    protobuf-native \
+    grpc-native \
+    grpc \
     systemd \
 "
 
@@ -15,21 +18,25 @@ PV = "2.0+git${SRCPV}"
 
 SRC_URI = " \
     git://gerrit.automotivelinux.org/gerrit/src/applaunchd;protocol=https;branch=${AGL_BRANCH}  \
+    file://applaunchd.service \
     file://agl-app@.service \
     file://agl-app-web@.service \
     file://agl-app-flutter@.service \
     file://no-network.conf \
     file://private-tmp.conf \
 "
-SRCREV = "c675bafdf15cc19276bd8276c34f56404a5ecb62"
+SRCREV = "c52afaf8b5c96136fe20e5d5a1332121d3b09ee9"
 
 S = "${WORKDIR}/git"
 
-inherit meson pkgconfig
+inherit meson pkgconfig systemd
+
+SYSTEMD_SERVICE:${PN} = "applaunchd.service"
 
 do_install:append() {
     # Install generic template for all agl-app services
     install -d ${D}${systemd_system_unitdir}
+    install -m 644 ${WORKDIR}/applaunchd.service ${D}${systemd_system_unitdir}/
     install -m 644 ${WORKDIR}/agl-app@.service ${D}${systemd_system_unitdir}/
     install -m 644 ${WORKDIR}/agl-app-web@.service ${D}${systemd_system_unitdir}/
     install -m 644 ${WORKDIR}/agl-app-flutter@.service ${D}${systemd_system_unitdir}/