agl-compositor_git: Bump SRCREV to latest 64/28564/2
authorMarius Vlad <marius.vlad@collabora.com>
Wed, 8 Mar 2023 11:50:48 +0000 (13:50 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 22 Mar 2023 02:59:56 +0000 (02:59 +0000)
This SRCREV bump updates includes some minor fixes when hot-plugging the
connector, and includes set_app_float, set_app_normal and
set_app_fullscreen together with an implementation for deactivation of
windows using the gRPC API.

With this bump we also provide a versioned so libexec_compositor library
rather than a generic unversioned one.

In detail the following changes have been added:

4e4624dee9850b4a4e5 grpc-proxy: Add set_app_fullscreen functionality
9eb8ca6ac7473107ebe shell: Reset normal state when getting back to maximized
359a0612e48d7d21d52 protocol: Add set_app_normal request
4af44df30c1784a69b9 protocol, grpc-proxy: Add support for set_app_float
65fc5191f046ad8c7ba protocol/grpc-proxy: Add deactivate_app request
28ec0cff16d62260fb1 compositor: Added layout_save/layout_restore
ee50083d93869aaa581 shell: Check for a valid ivi_surface
02fcb317161c08bcf02 shell: Check for invalid outputs passed on when activating
d98b08f1fcb6ff6ccc7 compositor: Fix memleak when disabling the output
53a039ff1c4b05aaacc ivi-compositor: Add support for multiple app_ids
ce8dd33f3762e0ec449 meson: Deprecate waltham and inform users of that
6fd11a88c4d3c82e33b meson: Bump to version 0.0.21
4003cfb04b7bae04c32 shell: Reset the area activation

Change-Id: I2a2ea18124a825e7e7709aab9c4a4285377a45b0
Signed-off-by: Marius Vlad <marius.vlad@collabora.com>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/28564
Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb

index a76da66..948305d 100644 (file)
@@ -12,7 +12,7 @@ DEPENDS = "wayland wayland-protocols wayland-native weston \
           ${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'waltham waltham-transmitter-plugin', '', d)}"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/agl-compositor.git;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "7ef34e0c465a7596f87866e88bc5a9eed2ca7c05"
+SRCREV = "4e4624dee9850b4a4e590dd0f0f2b3173bded085"
 AGL_BRANCH:aglnext = "next"
 SRCREV:aglnext = "${AUTOREV}"
 
@@ -32,7 +32,7 @@ FILES:${PN} = " \
     ${bindir}/agl-compositor \
     ${bindir}/agl-screenshooter \
     ${libdir}/agl-compositor/libexec_compositor.so.0 \
-    ${libdir}/agl-compositor/libexec_compositor.so.0.0.0 \
+    ${libdir}/agl-compositor/libexec_compositor.so.0.0.21 \
 "
 
 FILES:agl-shell-grpc-server = " \