weston-ini-conf: Add activate-by-default=false by default 18/29018/3
authorMarius Vlad <marius.vlad@collabora.com>
Wed, 14 Jun 2023 13:14:30 +0000 (16:14 +0300)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Thu, 22 Jun 2023 14:53:41 +0000 (14:53 +0000)
As all our platforms (flutter, qt, html5) are now capable of starting
and activating windows on their own, we can turn off the implicit
activation by default from the compositor.

We would remove it entirely from the configuration file once we won't
have any code in the compositor. Make it default for now.

Change-Id: I43df54cd2bba5f05612989b02ce99c63f93a5c2d
Signed-off-by: Marius Vlad <marius.vlad@collabora.com>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/29018
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb
meta-agl-core/recipes-graphics/wayland/weston-ini-conf/core.cfg

index e618a14..829d595 100644 (file)
@@ -64,7 +64,6 @@ do_compile() {
     sed -i -e '$ d' ${WORKDIR}/weston.ini.default
 
     cat ${WORKDIR}/weston.ini.default > ${WORKDIR}/weston.ini.default-no-activate
-    sed -i -e 's#\[core\]#[core]\nactivate-by-default=false#' ${WORKDIR}/weston.ini.default-no-activate
 
     # Do it again, but filter fragments to configure for landscape
     # and a corresponding landscape-inverted that is 180 degrees
@@ -92,7 +91,6 @@ do_compile() {
     sed -i -e '$ d' ${WORKDIR}/weston.ini.landscape-inverted
 
     cat ${WORKDIR}/weston.ini.landscape > ${WORKDIR}/weston.ini.landscape-no-activate
-    sed -i -e 's#\[core\]#[core]\nactivate-by-default=false#' ${WORKDIR}/weston.ini.landscape-no-activate
 }
 
 do_install:append() {