meta-agl-bsp: Fix rc.pvr.service dependency for meta-rcar-gen3 33/28133/2
authorScott Murray <scott.murray@konsulko.com>
Thu, 10 Nov 2022 20:45:15 +0000 (15:45 -0500)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Sun, 13 Nov 2022 21:53:33 +0000 (21:53 +0000)
Undo the out of date tweak of rc.pvr.service to make it a dependency
of weston@.service done in meta-rcar-gen3's gles-user-module recipe.
For now, just tweak the dependency back to weston.service in our
bbappend in meta-agl-bsp, this can be removed when meta-rcar-gen3
includes a fix.

Bug-AGL: SPEC-4607

Change-Id: I16ef13d2af9b2ed485ce8b98501f39bf96aba3e2
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/28133
ci-image-build: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account
Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-agl-bsp/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bbappend

index bd7fdf2..e191617 100644 (file)
@@ -11,4 +11,11 @@ do_install:append(){
         mv ${D}/lib/firmware ${D}${nonarch_base_libdir}/
         rm -rf ${D}/lib
     fi
+
+    # Undo upstream's out of date use of weston@.service
+    if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)} ; then
+        # Fix weston dependency, needs to be weston.service
+        sed -i 's/^RequiredBy=weston@.service$/RequiredBy=weston.service/' \
+                ${D}${systemd_system_unitdir}/rc.pvr.service
+    fi
 }