meta-app-framework: tweak agl-driver definition 60/27060/2
authorScott Murray <scott.murray@konsulko.com>
Tue, 21 Dec 2021 23:37:36 +0000 (18:37 -0500)
committerScott Murray <scott.murray@konsulko.com>
Wed, 22 Dec 2021 04:07:19 +0000 (04:07 +0000)
Tweak agl-driver user definition in agl-session recipe to ensure
it is a member of the video and display groups (the latter has
been added back to the static group file).  This is required to
avoid agl-compositor startup failures on rcar3.  The display
group membership potentially could be dropped if we were to
bbappend rcar3's gles-user-module recipe to tweak its udev rules.
For now, take the most straightforward approach.

Bug-AGL: SPEC-4161

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: I7237ade5d8680655f17716ac048349a476eb5f29
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/27060
Tested-by: Jenkins Job builder account
ci-image-build: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account

meta-agl-core/files/group
meta-app-framework/recipes-config/agl-session/agl-session_0.1.bb

index f524489..b04ff37 100644 (file)
@@ -86,6 +86,7 @@ lldpd::956:
 postdrop::954:
 weston::200:
 wayland::201:
+display::202:
 agl-driver::1001:
 agl-passenger::1002:
 systemd-network::1005:
index 6965333..dc7b5be 100644 (file)
@@ -13,10 +13,12 @@ inherit systemd allarch useradd
 USERADD_PACKAGES = "${PN}"
 USERADDEXTENSION = "useradd-staticids"
 GROUPADD_PARAM:${PN} = "\
+       --system display ; \
+       --system video ; \
        -g 1001 agl-driver ; \
 "
 USERADD_PARAM:${PN} = "\
-  -g 1001 -u 1001 -o -d /home/agl-driver -m -K PASS_MAX_DAYS=-1 agl-driver ; \
+  -g 1001 -u 1001 -G video,display -o -d /home/agl-driver -m -K PASS_MAX_DAYS=-1 agl-driver ; \
 "
 
 SYSTEMD_PACKAGES = "${PN}"