Restructure Salvator-x .inc files 01/29201/2
authorHau Vo <hau.vo.ra@renesas.com>
Tue, 22 Aug 2023 03:10:17 +0000 (12:10 +0900)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Mon, 11 Sep 2023 12:50:08 +0000 (12:50 +0000)
This commit restructure the .inc files relate to H3/M3 Salvator-x boards.

Bug-AGL: SPEC-4808

Signed-off-by: Hau Vo <hau.vo.ra@renesas.com>
Change-Id: I9e01f61f75010c1cbf54feec30422855b43cf051
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/29175
Reviewed-by: Harunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tested-by: Jenkins Job builder account
ci-image-build: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account
(cherry picked from commit 979598c6e9b855cec0ff56c95eae0d47e9c0e21a)
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/29201

meta-agl-bsp/conf/include/agl_h3-salvator-x-nogfx.inc
meta-agl-bsp/conf/include/agl_h3-salvator-x.inc
meta-agl-bsp/conf/include/agl_m3-salvator-x-nogfx.inc
meta-agl-bsp/conf/include/agl_m3-salvator-x.inc
meta-agl-bsp/conf/include/agl_salvator-nogfx.inc [new file with mode: 0644]
meta-agl-bsp/conf/include/agl_salvator.inc [new file with mode: 0644]

index 455a368..4ff103d 100644 (file)
@@ -1,25 +1,9 @@
-require conf/include/agl_rcar-nogfx.inc
+require conf/include/agl_salvator-nogfx.inc
 SOC_FAMILY = "r8a7795"
 BOARD_NAME = "h3-salvator-x"
 
 DTB_SUFFIX = "r8a77951-salvator-xs"
 
-# Mask graphic Pkgs
-BBMASK += "gles-user-module|kernel-module-gles|wayland-kms|libgbm"
-# Mask MMP recipes
-BBMASK += "kernel-module-uvcs-drv|omx-user-module"
-
-# Work around use of obsolete Weston backend-fbdev in meta-rcar-gen3
-# when building without the proprietary driver stack.  Masking out the
-# weston_%.bbappend seems the simplest approach for now, as forcing
-# USE_GLES = "1" to disable the adding of -Dbackend-default="fbdev" to
-# EXTRA_OEMESON triggers adding "libgbm" to DEPENDS, which breaks due
-# to that being a component specific to the proprietary stack we are
-# explicitly disabling.  If the "libgbm" usage in the bbappend was
-# instead "virtual/libgbm" as is now used in poky, it might be possible
-# to just tweak PREFERRED_PROVIDER_virtual/libgbm = "mesa".
-BBMASK += "meta-rcar-gen3/recipes-graphics/wayland/weston_%.bbappend"
-
 # do use software rendering to display the compositor
 # used for images w/o binary-only driver
 WESTON_USE_PIXMAN = "1"
index 46e1087..134b1dd 100644 (file)
@@ -1,9 +1,6 @@
-require conf/include/agl_rcar.inc
+require conf/include/agl_salvator.inc
 SOC_FAMILY = "r8a7795"
 BOARD_NAME = "h3-salvator-x"
 
 DTB_SUFFIX = "r8a77951-salvator-xs"
 
-IMAGE_INSTALL:append:rcar-gen3 = " \
-    kernel-module-vspm-if \
-"
index b50f363..ebbb300 100644 (file)
@@ -1,21 +1,6 @@
-require conf/include/agl_rcar-nogfx.inc
+require conf/include/agl_salvator-nogfx.inc
 SOC_FAMILY = "r8a7796"
 BOARD_NAME = "m3-salvator-x"
 
 DTB_SUFFIX = "r8a7796-salvator-xs"
 
-# Mask graphic Pkgs
-BBMASK += "gles-user-module|kernel-module-gles|wayland-kms|libgbm"
-# Mask MMP recipes
-BBMASK += "kernel-module-uvcs-drv|omx-user-module"
-
-# Work around use of obsolete Weston backend-fbdev in meta-rcar-gen3
-# when building without the proprietary driver stack.  Masking out the
-# weston_%.bbappend seems the simplest approach for now, as forcing
-# USE_GLES = "1" to disable the adding of -Dbackend-default="fbdev" to
-# EXTRA_OEMESON triggers adding "libgbm" to DEPENDS, which breaks due
-# to that being a component specific to the proprietary stack we are
-# explicitly disabling.  If the "libgbm" usage in the bbappend was
-# instead "virtual/libgbm" as is now used in poky, it might be possible
-# to just tweak PREFERRED_PROVIDER_virtual/libgbm = "mesa".
-BBMASK += "meta-rcar-gen3/recipes-graphics/wayland/weston_%.bbappend"
index b40834b..355040b 100644 (file)
@@ -1,9 +1,6 @@
-require conf/include/agl_rcar.inc
+require conf/include/agl_salvator.inc
 SOC_FAMILY = "r8a7796"
 BOARD_NAME = "m3-salvator-x"
 
 DTB_SUFFIX = "r8a7796-salvator-xs"
 
-IMAGE_INSTALL:append:rcar-gen3 = " \
-    kernel-module-vspm-if \
-"
diff --git a/meta-agl-bsp/conf/include/agl_salvator-nogfx.inc b/meta-agl-bsp/conf/include/agl_salvator-nogfx.inc
new file mode 100644 (file)
index 0000000..06e635c
--- /dev/null
@@ -0,0 +1,17 @@
+require conf/include/agl_rcar-nogfx.inc
+
+# Mask graphic Pkgs
+BBMASK += "gles-user-module|kernel-module-gles|wayland-kms|libgbm"
+# Mask MMP recipes
+BBMASK += "kernel-module-uvcs-drv|omx-user-module"
+# Work around use of obsolete Weston backend-fbdev in meta-rcar-gen3
+# when building without the proprietary driver stack.  Masking out the
+# weston_%.bbappend seems the simplest approach for now, as forcing
+# USE_GLES = "1" to disable the adding of -Dbackend-default="fbdev" to
+# EXTRA_OEMESON triggers adding "libgbm" to DEPENDS, which breaks due
+# to that being a component specific to the proprietary stack we are
+# explicitly disabling.  If the "libgbm" usage in the bbappend was
+# instead "virtual/libgbm" as is now used in poky, it might be possible
+# to just tweak PREFERRED_PROVIDER_virtual/libgbm = "mesa".
+BBMASK += "meta-rcar-gen3/recipes-graphics/wayland/weston_%.bbappend"
+
diff --git a/meta-agl-bsp/conf/include/agl_salvator.inc b/meta-agl-bsp/conf/include/agl_salvator.inc
new file mode 100644 (file)
index 0000000..7845786
--- /dev/null
@@ -0,0 +1,6 @@
+require conf/include/agl_rcar.inc
+
+IMAGE_INSTALL:append:rcar-gen3 = " \
+    kernel-module-vspm-if \
+"
+