Allow SRCREV handling through poky-agl.conf 85/11685/2
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>
Sun, 5 Nov 2017 11:54:08 +0000 (12:54 +0100)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Sun, 5 Nov 2017 15:12:16 +0000 (15:12 +0000)
This change simplifies the SRCREV handling by using
- AGL_APP_REVISION and AGL_DEFAULT_REVISION
in recipes.
Also the AGL_BRANCH can be used to switch to release branches.

Bug-AGL: SPEC-864

Change-Id: I9384c85d4f7434416d87359f88c482887ac2ead8
Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/11685
Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>

12 files changed:
meta-agl-distro/conf/distro/poky-agl.conf
meta-agl/recipes-devtools/low-level-can-generator/low-level-can-generator_git.bb
meta-agl/recipes-multimedia/pulseaudio/agl-audio-plugin_0.1.bb
meta-app-framework/recipes-apps/low-level-can-service/low-level-can-service_git.bb
meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
meta-app-framework/recipes-core/af-main/af-main_1.0.inc
meta-app-framework/recipes-example/afb-client/afb-client_1.0.bb
meta-app-framework/recipes-example/afm-client/afm-client_1.0.bb
meta-ivi-common/recipes-test/dung/dung_3.4.25-m2.bb
meta-ivi-common/recipes-test/ipv6connect/ipv6connect.bb
meta-ivi-common/recipes-test/linpack/linpack.bb
meta-ivi-common/recipes-test/linus-stress/linus-stress.bb

index 2ea5fda..22bcb4b 100644 (file)
@@ -3,12 +3,23 @@ require conf/distro/poky.conf
 # AGL specific derivations
 DISTRO = "poky-agl"
 DISTRO_NAME = "Automotive Grade Linux"
-DISTRO_VERSION = "4.99.1+snapshot-${DATE}"
+DISTRO_VERSION = "4.99.2+snapshot-${DATE}"
 DISTRO_CODENAME = "eel"
-DISTRO_BRANCH_VERSION_TAG = "eel/4.99.1"
+DISTRO_BRANCH_VERSION_TAG = "eel/4.99.2"
 SDK_VENDOR = "-aglsdk"
 SDK_VERSION := "${@'${DISTRO_VERSION}'.replace('snapshot-${DATE}','snapshot')}"
 
+AGL_BRANCH = "master"
+#for development
+#AGL_APP_REVISION = "${AUTOREV}"
+#for release
+AGL_APP_REVISION = "refs/tags/${DISTRO_BRANCH_VERSION_TAG}"
+#for development
+#AGL_DEFAULT_REVISION = "${AUTOREV}"
+#for release
+AGL_DEFAULT_REVISION = "refs/tags/${DISTRO_BRANCH_VERSION_TAG}"
+
+
 MAINTAINER = "AGL <automotive-discussions@lists.linuxfoundation.org>"
 
 TARGET_VENDOR = "-agl"
index 35fb318..d364939 100644 (file)
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7ca
 inherit cmake pkgconfig
 BBCLASSEXTEND = "nativesdk"
 
-SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/src/low-level-can-generator;protocol=https"
+SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/src/low-level-can-generator;protocol=https;branch=${AGL_BRANCH}"
 SRCREV = "92f95384ce4b4a198b1fea93272201421f7b9a39"
 
 PV = "4.0+git${SRCPV}"
index 196b76f..633a3e2 100644 (file)
@@ -12,7 +12,7 @@ DEPENDS = "json-c pulseaudio"
 RDEPENDS_${PN} = "pulseaudio-server pulseaudio-module-null-sink pulseaudio-module-loopback"
 
 SRCREV = "952d404e87ca6001e546fe9105bdb6760c468760"
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/agl-audio-plugin;protocol=https"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/agl-audio-plugin;protocol=https;branch=${AGL_BRANCH}"
 
 S = "${WORKDIR}/git"
 
index 994a461..828022b 100644 (file)
@@ -6,7 +6,7 @@ SECTION     = "apps"
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
 
-SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/low-level-can-service;protocol=https;branch=master"
+SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/low-level-can-service;protocol=https;branch=${AGL_BRANCH}"
 SRCREV = "a8eaf1f71c2906140b600314dfe935fab3a06bf2"
 
 PV = "4.0+git${SRCPV}"
index 0fc3a67..23dcb46 100644 (file)
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://LICENSE-2.0.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
 
 DEPENDS = "file json-c libmicrohttpd systemd util-linux openssl cynara"
 
-SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-binder;protocol=https;branch=master"
+SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-binder;protocol=https;branch=${AGL_BRANCH}"
 SRC_URI_files = ""
 SRC_URI = "${SRC_URI_git} \
            ${SRC_URI_files} \
index a2a7524..897da2b 100644 (file)
@@ -8,7 +8,7 @@ HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/src/app-f
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57"
 
-SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-main;protocol=https;branch=master"
+SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-main;protocol=https;branch=${AGL_BRANCH}"
 SRC_URI_files = ""
 SRC_URI = "${SRC_URI_git} \
            ${SRC_URI_files} \
index 21605d2..f272b26 100644 (file)
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=6cb04bdb88e11107e3af4d8e3f301be5"
 #DEPENDS = "nodejs-native"
 RDEPENDS_${PN} = "af-binder af-binder-binding-authlogin"
 
-SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-demo;protocol=https;branch=master"
+SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-demo;protocol=https;branch=${AGL_BRANCH}"
 SRC_URI_files = "file://afb-client \
           "
 SRC_URI = "${SRC_URI_git} \
index 4cd80db..159f69f 100644 (file)
@@ -12,7 +12,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=6cb04bdb88e11107e3af4d8e3f301be5"
 #DEPENDS = "nodejs-native"
 RDEPENDS_${PN} = "af-main af-binder af-main-binding af-binder-binding-demopost af-binder-binding-authlogin"
 
-SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-demo;protocol=https;branch=master"
+SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-demo;protocol=https;branch=${AGL_BRANCH}"
 SRC_URI_files = "file://afm-client \
            file://afm-client.service \
           "
index 190e4d7..28bf858 100644 (file)
@@ -2,7 +2,7 @@ SUMMARY = "Kernel test scripts"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/qa-test-misc;protocol=https;branch=master"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/qa-test-misc;protocol=https;branch=${AGL_BRANCH}"
 SRCREV = "e2472c7b1d061aef8bb05a4d7940fd8159c4a329"
 
 inherit allarch
index 208ac5c..a8b9371 100644 (file)
@@ -3,7 +3,7 @@ HOMEPAGE = "https://chromium.googlesource.com/chromiumos/third_party/autotest/+/
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://${S}/${PN}/LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/qa-test-misc;protocol=https;branch=master"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/qa-test-misc;protocol=https;branch=${AGL_BRANCH}"
 SRCREV = "b355b7e1f43a19938895964f314484ffd8a39542"
 
 inherit autotools
index e1716cd..84bed0f 100644 (file)
@@ -2,7 +2,7 @@ SUMMARY = "Linpack benchmark"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://${S}/${PN}/linpack.c;md5=076f1fd8d313056103f98d4253862eae"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/qa-test-misc;protocol=https;branch=master"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/qa-test-misc;protocol=https;branch=${AGL_BRANCH}"
 SRCREV = "920cae73a918d1f516113b0ae967be3ecaba86ef"
 
 DEPENDS += "rsync-native"
index 4651180..01b3cfc 100644 (file)
@@ -3,7 +3,7 @@ HOMEPAGE = "https://chromium.googlesource.com/chromiumos/third_party/autotest/+/
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://${S}/linus_stress/LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/qa-test-misc;protocol=https;branch=master"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/qa-test-misc;protocol=https;branch=${AGL_BRANCH}"
 SRCREV = "87cdfd4626c0cb47fc22f328867e49d6268df85c"
 
 inherit autotools