weston: Use drm-backend.so for Raspberry Pi 89/6589/2
authorLeon Anavi <leon.anavi@konsulko.com>
Thu, 22 Sep 2016 13:23:55 +0000 (16:23 +0300)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Sun, 25 Sep 2016 04:05:15 +0000 (04:05 +0000)
Replace weston.ini configration for Raspberry Pi
and use drm-backend.so as a backend for Weston.

Change-Id: I8acedd63fc0a124e4f369609270094c76b7e7f88
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston/weston-raspberrypi.ini [new file with mode: 0644]
meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston_%.bbappend [new file with mode: 0644]

diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston/weston-raspberrypi.ini b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston/weston-raspberrypi.ini
new file mode 100644 (file)
index 0000000..b491ac4
--- /dev/null
@@ -0,0 +1,8 @@
+[core]
+backend=drm-backend.so
+shell=desktop-shell.so
+
+[shell]
+locking=true
+# Uncomment below to hide panel
+#panel-location=none
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston_%.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston_%.bbappend
new file mode 100644 (file)
index 0000000..43f1da5
--- /dev/null
@@ -0,0 +1,15 @@
+FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+
+SRC_URI_append = "\
+    file://weston-raspberrypi.ini \
+    "
+
+do_install_append() {
+    WESTON_INI_CONFIG=${sysconfdir}/xdg/weston
+    install -d ${D}${WESTON_INI_CONFIG}
+    install -m 0644 ${WORKDIR}/weston-raspberrypi.ini ${D}${WESTON_INI_CONFIG}/weston.ini
+}
+
+FILES_${PN} += " \
+    ${sysconfdir}/xdg/weston/weston.ini \
+    "