Remove remaining "display" group usage 64/29364/2
authorScott Murray <scott.murray@konsulko.com>
Tue, 21 Nov 2023 23:02:41 +0000 (18:02 -0500)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Thu, 23 Nov 2023 15:04:41 +0000 (15:04 +0000)
Update the meta-rcar-gen3 driver specific bbappends to use the
"video" group instead of "display", and remove the weston-init
bbappend that was adding the "display" group when using it with
weston.  The group is no longer used in meta-rcar-gen3 or in any
of the AGL layers since the rework done for SPEC-4714; these
uses were missed at that time, and were causing permission issues
with the PVR driver initialization scripts.

Bug-AGL: SPEC-4979

Change-Id: I2efc8ea6e83b86e59def8a8333c8cc3064f8a7dd
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/29456
ci-image-boot-test: Jenkins Job builder account
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tested-by: Jenkins Job builder account
ci-image-build: Jenkins Job builder account
(cherry picked from commit 197314474d5d9eedfefde10fe31a848a78bd8a25)
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/29364

meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-init.bbappend [deleted file]
meta-agl-bsp/meta-rcar-gen3/recipes-multimedia/mmngr-module/mmngr-user-module.bbappend
meta-agl-bsp/meta-rcar-gen3/recipes-multimedia/mmngr-module/mmngrbuf-user-module.bbappend

diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-init.bbappend b/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-init.bbappend
deleted file mode 100644 (file)
index e4f5d29..0000000
+++ /dev/null
@@ -1,4 +0,0 @@
-# Add display group to default list for weston user
-USERADD_PARAM:${PN} = "--home /home/weston --shell /bin/sh --user-group -G video,input,display weston"
-
-GROUPADD_PARAM:${PN} = "--system display ; -r wayland"
index ce02192..9d3f5c6 100644 (file)
@@ -1,8 +1,8 @@
 do_install:append() {
-    # Add a rule to ensure the 'display' user has permission to access
+    # Add a rule to ensure the 'video' user has permission to access
     install -d ${D}${sysconfdir}/udev/rules.d
     cat >${D}${sysconfdir}/udev/rules.d/56-rgnmm.rules <<'EOF'
-KERNEL=="rgnmm", MODE="0660", GROUP="display"
+KERNEL=="rgnmm", MODE="0660", GROUP="video"
 EOF
 }
 
index 13fc03c..640e526 100644 (file)
@@ -1,8 +1,8 @@
 do_install:append() {
-    # Add a rule to ensure the 'display' user has permission to access
+    # Add a rule to ensure the 'video' group has permission to access
     install -d ${D}${sysconfdir}/udev/rules.d
     cat >${D}${sysconfdir}/udev/rules.d/56-rgnmmbuf.rules <<'EOF'
-KERNEL=="rgnmmbuf", MODE="0660", GROUP="display"
+KERNEL=="rgnmmbuf", MODE="0660", GROUP="video"
 EOF
 }