agl-compositor: Bump SRCREV 04/26604/6
authorMarius Vlad <marius.vlad@collabora.com>
Wed, 1 Sep 2021 14:46:10 +0000 (16:46 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Mon, 6 Sep 2021 12:05:37 +0000 (12:05 +0000)
This bumps up SRCREV to include 'compositor: Do not allow vt-switching
by default'.

Note this patch also includes

- re-building libweston with headless backend as lamprey was cut after
  some of the changes made into agl-compositor and it those it requires
  having the headless backend installed

- includes the libcompositor updates required to avoid QA build errors

- compliance with weston ini configuration wrt to loading up systemd
  plugin.

Bug-AGL: SPEC-4063

Signed-off-by: Marius Vlad <marius.vlad@collabora.com>
Change-Id: I9abbb84895de2e37d814ff0485ae0d004982fc34
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/26604
Tested-by: Jenkins Job builder account
ci-image-build: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb
meta-agl-core/recipes-graphics/wayland/weston_8.0_aglcore.inc

index 87df04e..0030e4a 100644 (file)
@@ -12,7 +12,7 @@ DEPENDS = "wayland wayland-protocols wayland-native weston \
           ${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'waltham waltham-transmitter-plugin', '', d)}"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/agl-compositor.git;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "68d184f9d541a475e15727d71f49b6df6799a054"
+SRCREV = "bd4c81d5f90d466df8019d19dca4856aa7a5fa80"
 
 PV = "0.0.10+git${SRCPV}"
 S = "${WORKDIR}/git"
@@ -28,5 +28,12 @@ FILES_${PN} = " \
                ${bindir}/agl-screenshooter \
                ${datadir}/${PN}/protocols/agl-shell.xml \
                ${datadir}/${PN}/protocols/agl-shell-desktop.xml \
+               ${libdir}/agl-compositor/libexec_compositor.so.0 \
+               ${libdir}/agl-compositor/libexec_compositor.so.0.0.0 \
               "
+
 RDEPENDS_${PN} += " ${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'waltham waltham-transmitter-plugin', '', d)}"
+
+FILES_${PN}-dev += " \
+        ${libdir}/agl-compositor/libexec_compositor.so \
+"
index 3c9bd4d..d29d09f 100644 (file)
@@ -6,6 +6,7 @@ SRC_URI_append = "\
 
 # Workaround for incorrect upstream definition
 PACKAGECONFIG[remoting] = "-Dremoting=true,-Dremoting=false,gstreamer1.0 gstreamer1.0-plugins-base"
+PACKAGECONFIG[headless] = "-Dbackend-headless=true"
 PACKAGECONFIG_append = "${@bb.utils.contains('DISTRO_FEATURES', 'weston-remoting', ' remoting', '', d)}"
 PACKAGECONFIG_append = "${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', ' remoting', '', d)}"