Fix dependency issue with grpc in meta-agl-core 09/28509/2
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Thu, 16 Feb 2023 11:34:49 +0000 (12:34 +0100)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Thu, 16 Feb 2023 16:56:36 +0000 (16:56 +0000)
grpc is not in the core layer but in meta-oe . Guard the dependency and only enable when
prerequisites are met.

Bug-AGL: SPEC-4707
Change-Id: I922a846108ca13d8e6d50e79c3003b0b32a002a7
Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/28509
Reviewed-by: Marius Vlad <marius.vlad@collabora.com>
Tested-by: Jenkins Job builder account
ci-image-build: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account

meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb

index d4f5ce7..ea0410a 100644 (file)
@@ -22,6 +22,7 @@ S = "${WORKDIR}/git"
 PACKAGECONFIG ?= ""
 PACKAGECONFIG[policy-rba] = "-Dpolicy-default=rba,,librba,librba rba-config"
 PACKAGECONFIG[policy-deny-all] = "-Dpolicy-default=deny-all,,"
+PACKAGECONFIG[grpc-proxy] = "-Dgrpc-proxy=true,-Dgrpc-proxy=false"
 
 inherit meson pkgconfig python3native