[RCAR] Fix block device performance decreased 77/27177/2
authorRonan Le Martret <ronan.lemartret@iot.bzh>
Fri, 28 Jan 2022 14:34:25 +0000 (15:34 +0100)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 15 Feb 2022 22:13:45 +0000 (22:13 +0000)
* After the RCAR BSP 5.5.O, the block device performance decreased.

The root cause is a change in the default kernel configuration of the BSP
(CPU Frequency scaling) from (RCAR BSP 4.7.0):

CONFIG_CPU_FREQ_DEFAULT_GOV_PERFORMANCE=y
\# CONFIG_CPU_FREQ_DEFAULT_GOV_SCHEDUTIL is not set

To its new default (RCAR BSP 5.5.0)

\# CONFIG_CPU_FREQ_DEFAULT_GOV_PERFORMANCE is not set
CONFIG_CPU_FREQ_DEFAULT_GOV_SCHEDUTIL=y

You can check current value at runtime using:

cat /sys/devices/system/cpu/cpufreq/policy0/scaling_governor
cat /sys/devices/system/cpu/cpufreq/policy4/scaling_governor

To mediate the regression we do switch back to the PERFORMANCE governor.

Bug-AGL: SPEC-4205

Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
Change-Id: I6d19d92dae9dd8c7977e2034215fce07d8318773
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/27108
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tested-by: Jenkins Job builder account
(cherry picked from commit d32ed899583ab14e6442f76dd1c78695f9c0ec33)
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/27177
ci-image-build: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account

meta-agl-bsp/meta-rcar-gen3/recipes-kernel/linux/files/Set_GOV_PERFORMANCE.cfg [new file with mode: 0644]
meta-agl-bsp/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_%.bbappend

diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-kernel/linux/files/Set_GOV_PERFORMANCE.cfg b/meta-agl-bsp/meta-rcar-gen3/recipes-kernel/linux/files/Set_GOV_PERFORMANCE.cfg
new file mode 100644 (file)
index 0000000..b020174
--- /dev/null
@@ -0,0 +1,2 @@
+CONFIG_CPU_FREQ_DEFAULT_GOV_PERFORMANCE=y
+# CONFIG_CPU_FREQ_DEFAULT_GOV_SCHEDUTIL is not set
index eccac30..3665664 100644 (file)
@@ -8,6 +8,7 @@ SRC_URI:append = " \
 "
 
 AGL_KCONFIG_FRAGMENTS += "namespace_fix.cfg"
+AGL_KCONFIG_FRAGMENTS += "Set_GOV_PERFORMANCE.cfg"
 
 # For Xen
 AGL_KCONFIG_FRAGMENTS += " \