meta-agl-bsp: meta-raspberrypi updates for YP 3.1.2 81/25081/2
authorScott Murray <scott.murray@konsulko.com>
Fri, 7 Aug 2020 18:05:25 +0000 (14:05 -0400)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Thu, 13 Aug 2020 10:10:14 +0000 (10:10 +0000)
Changes include:
- Rename bcm2835-bootfiles.bbappend to bootfiles.bbappend to match
  the recipe rename done in meta-raspberrypi
- Update bootfile paths in rpi-config_git.bbappend to match the rename
  done in meta-raspberrypi
- Remove local u-boot bbappend, as none of its changes are required
  with latest meta-raspberrypi and meta-updater
- A previously silently failing command in the create-combined-dtb
  recipe's do_install when building with agl-sota enabled now triggers
  a build failure, logic has been added to handle meta-updater's
  disabling of the required overlay file.

Bug-AGL: SPEC-3529

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: Ib5fd9f308fcd2da76ae882dd5b2413e56d3eee40
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25081
Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/bootfiles.bbappend [moved from meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bbappend with 100% similarity]
meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/files/0001-board-raspberrypi-add-serial-and-revision-to-the-dev-2019.07.patch [deleted file]
meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot_2020.01.bbappend [deleted file]
meta-agl-bsp/meta-raspberrypi/recipes-kernel/create-combined-dtb/create-combined-dtb_1.0.0.bb

index 9891fa2..bbab3df 100644 (file)
@@ -4,49 +4,49 @@ TOTAL_BOARD_MEM = "3072"
 do_deploy_append_raspberrypi4() {
     # ENABLE CAN
     if [ "${ENABLE_CAN}" = "1" ]; then
-        echo "# Enable CAN" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
-        echo "dtoverlay=mcp2515-can0,oscillator=16000000,interrupt=25" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+        echo "# Enable CAN" >>${DEPLOYDIR}/bootfiles/config.txt
+        echo "dtoverlay=mcp2515-can0,oscillator=16000000,interrupt=25" >>${DEPLOYDIR}/bootfiles/config.txt
     fi
 
     # Handle setup with armstub file
     if [ -n "${ARMSTUB}" ]; then
-        echo "\n# ARM stub configuration" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
-        echo "armstub=${ARMSTUB}" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+        echo "\n# ARM stub configuration" >> ${DEPLOYDIR}/bootfiles/config.txt
+        echo "armstub=${ARMSTUB}" >> ${DEPLOYDIR}/bootfiles/config.txt
         case "${ARMSTUB}" in
             *-gic.bin)
-                echo  "enable_gic=1" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+                echo  "enable_gic=1" >> ${DEPLOYDIR}/bootfiles/config.txt
                 ;;
         esac
     fi
 
     if [ "${AGL_XEN_WANTED}" = "1" ]; then
-        echo "total_mem=${TOTAL_BOARD_MEM}" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+        echo "total_mem=${TOTAL_BOARD_MEM}" >> ${DEPLOYDIR}/bootfiles/config.txt
     fi
 }
 
 do_deploy_append() {
     if [ "${ENABLE_CMA}" = "1" ] && [ -n "${CMA_LWM}" ]; then
-        sed -i '/#cma_lwm/ c\cma_lwm=${CMA_LWM}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+        sed -i '/#cma_lwm/ c\cma_lwm=${CMA_LWM}' ${DEPLOYDIR}/bootfiles/config.txt
     fi
 
     if [ "${ENABLE_CMA}" = "1" ] && [ -n "${CMA_HWM}" ]; then
-        sed -i '/#cma_hwm/ c\cma_hwm=${CMA_HWM}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+        sed -i '/#cma_hwm/ c\cma_hwm=${CMA_HWM}' ${DEPLOYDIR}/bootfiles/config.txt
     fi
 
-    echo "avoid_warnings=2" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
-    echo "mask_gpu_interrupt0=0x400" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
-    echo "dtoverlay=vc4-kms-v3d-overlay,cma-256" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
-    echo "dtoverlay=rpi-ft5406-overlay" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
-    echo "dtparam=audio=on" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+    echo "avoid_warnings=2" >> ${DEPLOYDIR}/bootfiles/config.txt
+    echo "mask_gpu_interrupt0=0x400" >> ${DEPLOYDIR}/bootfiles/config.txt
+    echo "dtoverlay=vc4-kms-v3d-overlay,cma-256" >> ${DEPLOYDIR}/bootfiles/config.txt
+    echo "dtoverlay=rpi-ft5406-overlay" >> ${DEPLOYDIR}/bootfiles/config.txt
+    echo "dtparam=audio=on" >> ${DEPLOYDIR}/bootfiles/config.txt
 }
 
 do_deploy_append_raspberrypi4() {
-    echo -e "\n[pi4]" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
-    echo "max_framebuffers=2" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+    echo -e "\n[pi4]" >> ${DEPLOYDIR}/bootfiles/config.txt
+    echo "max_framebuffers=2" >> ${DEPLOYDIR}/bootfiles/config.txt
 }
 
 do_deploy_append_sota() {
-    echo "device_tree_address=0x0c800000" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+    echo "device_tree_address=0x0c800000" >> ${DEPLOYDIR}/bootfiles/config.txt
 }
 
 ENABLE_UART_raspberrypi3 = "1"
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/files/0001-board-raspberrypi-add-serial-and-revision-to-the-dev-2019.07.patch b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/files/0001-board-raspberrypi-add-serial-and-revision-to-the-dev-2019.07.patch
deleted file mode 100644 (file)
index 964cdb7..0000000
+++ /dev/null
@@ -1,82 +0,0 @@
-From 86cc911aaa958fedf2ea9cb04b4af17f5357815d Mon Sep 17 00:00:00 2001
-From: Anton Gerasimov <anton.gerasimov@here.com>
-Date: Fri, 1 Feb 2019 14:39:48 +0100
-Subject: [PATCH] board: raspberrypi: add serial and revision to the device
- tree
-
-Raspberry Pi bootloader adds this node to fdt, but if u-boot script
-doesn't reuse the tree provided by it, this information is lost.
-
-Revision and serial are displayed in /proc/cpuinfo after boot.
-
-Signed-off-by: Anton Gerasimov <anton.gerasimov@here.com>
----
- board/raspberrypi/rpi/rpi.c | 31 +++++++++++++++++++++++++++++--
- 1 file changed, 29 insertions(+), 2 deletions(-)
-
-diff --git a/board/raspberrypi/rpi/rpi.c b/board/raspberrypi/rpi/rpi.c
-index 35f5939552..114178397e 100644
---- a/board/raspberrypi/rpi/rpi.c
-+++ b/board/raspberrypi/rpi/rpi.c
-@@ -241,6 +241,8 @@ static uint32_t rev_scheme;
- static uint32_t rev_type;
- static const struct rpi_model *model;
-+uint64_t serial;
-+
- #ifdef CONFIG_ARM64
- static struct mm_region bcm2837_mem_map[] = {
-       {
-@@ -384,8 +386,8 @@ static void set_serial_number(void)
-               return;
-       }
--      snprintf(serial_string, sizeof(serial_string), "%016llx",
--               msg->get_board_serial.body.resp.serial);
-+      serial = msg->get_board_serial.body.resp.serial;
-+      snprintf(serial_string, sizeof(serial_string), "%016llx", serial);
-       env_set("serial#", serial_string);
- }
-@@ -478,6 +480,29 @@ void *board_fdt_blob_setup(void)
-       return (void *)fw_dtb_pointer;
- }
-+static int ft_add_revision_info(void *blob) {
-+      int off;
-+      int ret;
-+
-+      off = fdt_subnode_offset(blob, 0, "system");
-+
-+      if (off < 0) {
-+              off = fdt_add_subnode(blob, 0, "system");
-+              if (off < 0)
-+                      return -1;
-+      }
-+
-+      ret = fdt_setprop_u64(blob, off, "linux,serial", serial);
-+      if (ret < 0)
-+              return -1;
-+
-+      ret = fdt_setprop_u32(blob, off, "linux,revision", revision);
-+      if (ret < 0)
-+              return -1;
-+
-+      return 0;
-+}
-+
- int ft_board_setup(void *blob, bd_t *bd)
- {
-       /*
-@@ -487,6 +512,8 @@ int ft_board_setup(void *blob, bd_t *bd)
-        */
-       lcd_dt_simplefb_add_node(blob);
-+      ft_add_revision_info(blob);
-+
- #ifdef CONFIG_EFI_LOADER
-       /* Reserve the spin table */
-       efi_add_memory_map(0, 1, EFI_RESERVED_MEMORY_TYPE, 0);
--- 
-2.17.1
-
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot_2020.01.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot_2020.01.bbappend
deleted file mode 100644 (file)
index ba2ecb5..0000000
+++ /dev/null
@@ -1,7 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-
-# Update the patch for u-boot 2019.07
-SRC_URI_remove_sota = "file://0001-board-raspberrypi-add-serial-and-revision-to-the-dev.patch"
-SRC_URI_append_sota = "file://0001-board-raspberrypi-add-serial-and-revision-to-the-dev-2019.07.patch"
-
-DEPENDS_append_rpi = " rpi-u-boot-scr"
index c82e6fd..c365715 100644 (file)
@@ -22,7 +22,8 @@ do_compile () {
        if [ -f "${DEPLOY_DIR_IMAGE}/bcm2710-rpi-3-b.dtb" ]; then
                fdtoverlay -v -i ${DEPLOY_DIR_IMAGE}/bcm2710-rpi-3-b.dtb -o bcm2710-rpi-3-b+vc4+ft5406.dtb ${DEPLOY_DIR_IMAGE}/rpi-ft5406.dtbo ${DEPLOY_DIR_IMAGE}/${VC4DTBO}.dtbo
        fi
-       if [ -f "${DEPLOY_DIR_IMAGE}/bcm2711-rpi-4-b.dtb" ]; then
+       # NOTE: meta-updater currently disables rpi-ft5406.dtbo on rpi4, so need to check if it is present
+       if [ -f "${DEPLOY_DIR_IMAGE}/bcm2711-rpi-4-b.dtb" -a -f "${DEPLOY_DIR_IMAGE}/rpi-ft5406.dtbo" ]; then
                fdtoverlay -v -i ${DEPLOY_DIR_IMAGE}/bcm2711-rpi-4-b.dtb -o bcm2711-rpi-4-b+vc4+ft5406.dtb ${DEPLOY_DIR_IMAGE}/rpi-ft5406.dtbo ${DEPLOY_DIR_IMAGE}/${VC4DTBO}.dtbo
        fi