Allow meta-agl-bsp to dynamically include recipes on demand 31/5531/2
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>
Thu, 14 Apr 2016 16:10:01 +0000 (18:10 +0200)
committerGerrit Code Review <gerrit@172.30.200.200>
Sun, 1 May 2016 21:39:01 +0000 (21:39 +0000)
This changeset introduces an improved handling of the recipe inclusion mechanism
that allows us to conditionally include fixes for bsp's once (and only once) they
are activated.
This overcomes the need to use BB_DANGLINGAPPENDS_WARNONLY = 1 that was introduced
in changeset 5527. Thus it can be removed again.

Change-Id: I7ea10748e3015e781f1e96cfc01ac54e83d0cd5a
Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
meta-agl-bsp/conf/layer.conf
meta-agl-bsp/meta-ti/.gitkeep [new file with mode: 0644]

index b0010f7..c78c762 100644 (file)
@@ -1,9 +1,11 @@
 # We have a conf and classes directory, add to BBPATH
 BBPATH =. "${LAYERDIR}:"
 
 # We have a conf and classes directory, add to BBPATH
 BBPATH =. "${LAYERDIR}:"
 
-# We have recipes-* directories, add to BBFILES
-BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
-            ${LAYERDIR}/recipes-*/*/*.bbappend"
+# Let us add layer-specific bbappends which are only applied when that
+# layer is included in our configuration -
+# e.g. only add layers if a bsp is present.
+BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bbappend' % layer \
+               for layer in BBFILE_COLLECTIONS.split())}"
 
 BBFILE_COLLECTIONS += "aglbsp"
 BBFILE_PATTERN_aglbsp = "^${LAYERDIR}/"
 
 BBFILE_COLLECTIONS += "aglbsp"
 BBFILE_PATTERN_aglbsp = "^${LAYERDIR}/"
diff --git a/meta-agl-bsp/meta-ti/.gitkeep b/meta-agl-bsp/meta-ti/.gitkeep
new file mode 100644 (file)
index 0000000..e69de29