AMB (automotive-message-broker): RDEPEND on python-curses
[AGL/meta-agl.git] / meta-ivi-common / recipes-automotive / automotive-message-broker / automotive-message-broker_git.bb
index 7c49e6c..dee6f59 100644 (file)
@@ -4,37 +4,25 @@ away from applications and provides a standard API for applications to easily \
 get the required information"
 
 HOMEPAGE = "https://github.com/otcshare/automotive-message-broker/wiki"
-LICENSE = "LGPL-2.1"
-LIC_FILES_CHKSUM = "file://COPYING;md5=b42382de5d854b9bb598acf2e8827de3"
 
-inherit cmake systemd
+require automotive-message-broker_git.inc
 
-PV = "0.12+git${SRCPV}"
+CMAKE_QT5_CLASS = "${@bb.utils.contains('BBFILE_COLLECTIONS','qt5-layer','cmake_qt5','',d)}"
+inherit cmake systemd ${CMAKE_QT5_CLASS}
 
-# The 'gpsd' leads to a conflict between bluez4 and bluez5 because
-# meta-openembedded/meta-oe/recipes-navigation/gpsd/gpsd_3.10.bb is able to
-# select  bluez4 only instead AGL Distro choose bluez5 at changeset 4141.
-# <https://gerrit.automotivelinux.org/gerrit/#/c/4141/>
-#
-# As temporary treatment, removing 'gpsd' from DEPENDS will let bitbake to build correctly.
-#
-#DEPENDS = "glib-2.0 util-linux sqlite3 qtbase boost json-c libtool gpsd"
 DEPENDS = "glib-2.0 util-linux sqlite3 boost json-c libtool"
-RDEPENDS_${PN} = "python-misc python-json"
+RDEPENDS_${PN} = "python-misc python-json python-curses"
 
-SRC_URI = "git://github.com/otcshare/automotive-message-broker.git"
-SRCREV = "ac3fe53327a13afc571efe079a31a0472ea285a3"
-
-SRC_URI += "file://amb_allow_sessionbus.patch \
-            file://ambd.service \
-            "
+PACKAGECONFIG ??= " use_gps \
+    ${@bb.utils.contains('BBFILE_COLLECTIONS','qt5-layer','use_qt5','', d)} \
+    "
+PACKAGECONFIG[use_gps] = "-Dgpsnmea_plugin=On"
+PACKAGECONFIG[use_qt5] = "-Dqtmainloop=On -Dqt_bindings=On,,qtbase qtdeclarative"
 
 SYSTEMD_PACKAGES = "${PN}"
 SYSTEMD_SERVICE_${PN} = "ambd.service"
 
-S = "${WORKDIR}/git"
-
-# amb detects icecc in cmake and would override the 
+# amb detects icecc in cmake and would override the
 # compiler selection of yocto. This breaks the build
 # if icecc is installed on the host.
 # -> Disable the detection in cmake.
@@ -42,9 +30,19 @@ EXTRA_OECMAKE += " -Denable_icecc=OFF"
 
 do_install_append() {
     mv ${D}/usr/include/amb/* ${D}/usr/include
+    sed -i 's,/amb,,' ${D}${libdir}/pkgconfig/*.pc
 
     install -d ${D}${systemd_unitdir}/system/
     install -m 0644 ${WORKDIR}/ambd.service ${D}${systemd_unitdir}/system
+
+    if [ "${@bb.utils.contains('PACKAGECONFIG', 'use_gps', 'use_gps', '', d)}" = "use_gps" ]; then
+        install -m 0644 ${WORKDIR}/gps ${D}/${sysconfdir}/ambd/plugins.d
+    fi
 }
 
-FILES_${PN} += "${systemd_unitdir}/ambd.service"
+FILES_${PN} += " ${systemd_unitdir}/ambd.service \
+    ${@bb.utils.contains('BBFILE_COLLECTIONS','qt5-layer','${libdir}/qt5/qml/amb/','',d)} \
+    "
+FILES_${PN}-dbg += " \
+    ${@bb.utils.contains('BBFILE_COLLECTIONS', 'qt5-layer', '${libdir}/qt5/qml/amb/.debug', '', d)} \
+    "