AMB (automotive-message-broker): RDEPEND on python-curses 49/4449/1
authorManuel Bachmann <mbc@iot.bzh>
Wed, 9 Dec 2015 11:47:46 +0000 (11:47 +0000)
committerManuel Bachmann <mbc@iot.bzh>
Wed, 9 Dec 2015 17:31:49 +0000 (17:31 +0000)
Current RDEPENDS are OK for "amb-get, amb-set, ..." utils,
but they are deprecated in favor of "ambctl". This one
depends on python-curses, thus add it to make it work.

Change-Id: Ibbc8d0a0c71c68cdf3315c9fe86f8e257dc8ebff
Signed-off-by: Manuel Bachmann <mbc@iot.bzh>
meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.bb

index 77f14a0..dee6f59 100644 (file)
@@ -11,7 +11,7 @@ CMAKE_QT5_CLASS = "${@bb.utils.contains('BBFILE_COLLECTIONS','qt5-layer','cmake_
 inherit cmake systemd ${CMAKE_QT5_CLASS}
 
 DEPENDS = "glib-2.0 util-linux sqlite3 boost json-c libtool"
-RDEPENDS_${PN} = "python-misc python-json"
+RDEPENDS_${PN} = "python-misc python-json python-curses"
 
 PACKAGECONFIG ??= " use_gps \
     ${@bb.utils.contains('BBFILE_COLLECTIONS','qt5-layer','use_qt5','', d)} \