improves install mode setting
[AGL/meta-agl.git] / meta-agl / recipes-multimedia / lightmediascanner / lightmediascanner_%.bbappend
index f9c269d..521724f 100644 (file)
@@ -10,7 +10,7 @@ inherit systemd
 do_install_append() {
        # Install LMS systemd service
        if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
-              install -p -D ${WORKDIR}/lightmediascanner.service ${D}${systemd_user_unitdir}/lightmediascanner.service
+              install -m 644 -p -D ${WORKDIR}/lightmediascanner.service ${D}${systemd_user_unitdir}/lightmediascanner.service
 
               # Execute these manually on behalf of systemctl script (from systemd-systemctl-native.bb)
               # because it does not support systemd's user mode.