improves install mode setting 23/5323/2
authorJosé Bollo <jose.bollo@iot.bzh>
Wed, 20 Jan 2016 15:58:29 +0000 (16:58 +0100)
committerGerrit Code Review <gerrit@172.30.200.200>
Thu, 21 Jan 2016 21:18:18 +0000 (21:18 +0000)
When using install, the default mode value is 0755
that installs the files as executables.

This patch removes that unexpected mode.

Change-Id: I73e902a8907f98e94b5abaaf81d6c35ad98b0eb0
Signed-off-by: José Bollo <jose.bollo@iot.bzh>
meta-agl/recipes-connectivity/rygel/rygel_%.bbappend
meta-agl/recipes-core/dbus/dbus_%.bbappend
meta-agl/recipes-core/systemd/systemd_%.bbappend
meta-agl/recipes-graphics/wayland/weston_%.bbappend
meta-agl/recipes-multimedia/lightmediascanner/lightmediascanner_%.bbappend

index 3f3f749..9d4713c 100644 (file)
@@ -13,7 +13,7 @@ inherit systemd
 do_install_append() {
        # Install rygel systemd service
        if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
-              install -p -D ${WORKDIR}/rygel.service ${D}${systemd_user_unitdir}/rygel.service
+              install -m 644 -p -D ${WORKDIR}/rygel.service ${D}${systemd_user_unitdir}/rygel.service
 
               # Execute these manually on behalf of systemctl script (from systemd-systemctl-native.bb)
               # because it does not support systemd's user mode.
index 348be60..b27e44d 100644 (file)
@@ -9,9 +9,9 @@ inherit systemd
 
 do_install_append() {
     if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
-        install -p -D ${WORKDIR}/dbus.service ${D}${systemd_user_unitdir}/dbus.service
-        install -p -D ${WORKDIR}/dbus.socket ${D}${systemd_user_unitdir}/dbus.socket
-        install -p -D ${WORKDIR}/dbus_env.conf ${D}${systemd_system_unitdir}/user@.service.d/dbus_env.conf
+        install -m 644 -p -D ${WORKDIR}/dbus.service ${D}${systemd_user_unitdir}/dbus.service
+        install -m 644 -p -D ${WORKDIR}/dbus.socket ${D}${systemd_user_unitdir}/dbus.socket
+        install -m 644 -p -D ${WORKDIR}/dbus_env.conf ${D}${systemd_system_unitdir}/user@.service.d/dbus_env.conf
 
         # Execute these manually on behalf of systemctl script (from systemd-systemctl-native.bb)
         # because it does not support systemd's user mode.
index ef92695..4e0d5d4 100644 (file)
@@ -7,7 +7,7 @@ PACKAGECONFIG_append_pn-systemd = " networkd"
 
 do_install_append() {
     # Install /etc/e2fsck.conf to avoid boot stuck by wrong clock time
-    install -p -D ${WORKDIR}/e2fsck.conf ${D}/etc/e2fsck.conf
+    install -m 644 -p -D ${WORKDIR}/e2fsck.conf ${D}/etc/e2fsck.conf
 }
 
 FILES_${PN} += " /etc/e2fsck.conf "
index 2ee7150..6ad42fc 100644 (file)
@@ -13,7 +13,7 @@ SYSTEMD_SERVICE_${PN} = "weston.service"
 do_install_append() {
     # Install systemd unit files
     if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
-        install -p -D ${WORKDIR}/weston.service ${D}${systemd_system_unitdir}/weston.service
+        install -m 644 -p -D ${WORKDIR}/weston.service ${D}${systemd_system_unitdir}/weston.service
     fi
 
     WESTON_INI_CONFIG=${sysconfdir}/xdg/weston
index f9c269d..521724f 100644 (file)
@@ -10,7 +10,7 @@ inherit systemd
 do_install_append() {
        # Install LMS systemd service
        if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
-              install -p -D ${WORKDIR}/lightmediascanner.service ${D}${systemd_user_unitdir}/lightmediascanner.service
+              install -m 644 -p -D ${WORKDIR}/lightmediascanner.service ${D}${systemd_user_unitdir}/lightmediascanner.service
 
               # Execute these manually on behalf of systemctl script (from systemd-systemctl-native.bb)
               # because it does not support systemd's user mode.