Support MinnowBoard MAX
[AGL/meta-agl.git] / meta-agl / recipes-core / systemd / systemd_%.bbappend
index 29b7d1d..ef92695 100644 (file)
@@ -1,3 +1,13 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += " file://e2fsck.conf "
+
 # enable networkd support
 PACKAGECONFIG_append_pn-systemd = " networkd"
 
+do_install_append() {
+    # Install /etc/e2fsck.conf to avoid boot stuck by wrong clock time
+    install -p -D ${WORKDIR}/e2fsck.conf ${D}/etc/e2fsck.conf
+}
+
+FILES_${PN} += " /etc/e2fsck.conf "