improves install mode setting
[AGL/meta-agl.git] / meta-agl / recipes-connectivity / rygel / rygel_%.bbappend
index 3f3f749..9d4713c 100644 (file)
@@ -13,7 +13,7 @@ inherit systemd
 do_install_append() {
        # Install rygel systemd service
        if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
-              install -p -D ${WORKDIR}/rygel.service ${D}${systemd_user_unitdir}/rygel.service
+              install -m 644 -p -D ${WORKDIR}/rygel.service ${D}${systemd_user_unitdir}/rygel.service
 
               # Execute these manually on behalf of systemctl script (from systemd-systemctl-native.bb)
               # because it does not support systemd's user mode.