add layer meta-netboot to enable network boot over NBD (Network Block Device)
[AGL/meta-agl.git] / meta-netboot / recipes-core / initramfs-netboot / initramfs-netboot_1.0.bb
1 SUMMARY = "Extremely basic live image init script"
2 LICENSE = "MIT"
3 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4 SRC_URI = "file://init.sh"
5
6 S = "${WORKDIR}"
7
8 do_install() {
9         install -dm 0755 ${D}/etc
10         touch ${D}/etc/initrd-release
11         install -dm 0755 ${D}/dev
12         install -dm 0755 ${D}/sbin
13         install -m 0755 ${WORKDIR}/init.sh ${D}/sbin/init
14 }
15
16 inherit allarch
17
18 FILES_${PN} += " /dev /etc/initrd-release /sbin/init "
19