add layer meta-netboot to enable network boot over NBD (Network Block Device)
[AGL/meta-agl.git] / meta-netboot / recipes-core / images / initramfs-netboot-image.bb
1 # Netboot initramfs image.
2 DESCRIPTION = "Netboot initrd image"
3
4 PACKAGE_INSTALL = "initramfs-netboot busybox base-passwd ${ROOTFS_BOOTSTRAP_INSTALL}"
5
6 # Do not pollute the initrd image with rootfs features
7 IMAGE_FEATURES = ""
8
9 export IMAGE_BASENAME = "initramfs-netboot-image"
10 IMAGE_LINGUAS = ""
11
12 LICENSE = "MIT"
13
14 IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
15 inherit core-image
16
17 IMAGE_ROOTFS_SIZE = "8192"
18
19 BAD_RECOMMENDATIONS += "busybox-syslog"