agl-selinux: pull in meta-clang
[AGL/meta-agl.git] / meta-netboot / classes / netboot.bbclass
1 # Enable network bootable image and initrd/initramfs
2
3 OVERRIDES .= ":netboot"
4 # add 512MB of extra space in ext4 output image
5 IMAGE_ROOTFS_EXTRA_SPACE = "524288"
6 NETBOOT_ENABLED ??= "1"
7
8 python () {
9     if (bb.utils.contains("IMAGE_FSTYPES","live",True,False,d)):
10         # typical case for Minnowboard Max
11         d.setVar("INITRD_IMAGE","initramfs-netboot-image")
12         d.setVar("INITRD_IMAGE_LIVE",d.getVar("INITRD_IMAGE",True))
13         d.setVar("INITRD_LIVE","%s/%s-%s.ext4.gz" % (
14             d.getVar("DEPLOY_DIR_IMAGE",True),
15             d.getVar("INITRD_IMAGE_LIVE",True),
16             d.getVar("MACHINE",True)
17         ))
18     else:
19         d.setVar("INITRAMFS_IMAGE","initramfs-netboot-image")
20         if (d.getVar("KERNEL_IMAGETYPE",True) == "uImage"):
21             # case for "old" u-boot images, like Porter board
22             d.setVar("NETBOOT_FSTYPES", "ext4.gz.u-boot");
23         else:
24             # case for new u-boot images which don't require uImage format
25             d.setVar("NETBOOT_FSTYPES", "ext4.gz");
26 }
27