Provide automatic DHCP configuration for Ethernet adapters
[AGL/meta-agl.git] / meta-ivi-common / recipes-test / wayland / wayland-fits_git.bb
1 SUMMARY = "Wayland-fits, the Wayland Functional Integration Test Suite"
2 DESCRIPTION = "Wayland-fits is a fully automated functional integration \
3 test suite. Its main purpose is to test the functionality and integration of \
4 client-side (i.e. toolkit) and server-side (compositor) implementations of \
5 the Wayland protocol."
6 HOMEPAGE = "https://github.com/01org/wayland-fits"
7 LICENSE = "MIT"
8 LIC_FILES_CHKSUM = "file://COPYING;md5=f8d34cadaf891753c0f00c6cd48f08f5 \
9                     file://src/extensions/weston/weston-wfits.cpp;endline=21;md5=848c81e55cf3a30a9f6ed75f0dba7a97"
10
11 SRC_URI = "git://github.com/01org/wayland-fits.git"
12 SRCREV = "f30dfa9fceb438d3687c5215093fffc21a7852fc"
13
14 S = "${WORKDIR}/git"
15
16 inherit autotools pkgconfig
17
18 DEPENDS = "libcheck boost wayland weston"
19 RDEPENDS_${PN} = "weston"
20
21 EXTRA_OECONF += "--enable-shared --disable-static --with-boost-libdir=${STAGING_LIBDIR}"
22
23 PACKAGECONFIG ??= "elementary gtk+3"
24
25 PACKAGECONFIG[elementary] = "--enable-efl-tests,--disable-efl-tests,elementary"
26 PACKAGECONFIG[gtk+3] = "--enable-gtk-tests,--disable-gtk-tests,gtk+3"
27
28 do_install_append() {
29         rm -f ${D}/${libdir}/weston/*.la
30 }
31
32 FILES_${PN} += "${bindir}/wfits ${libdir}/weston/*.so"
33 FILES_${PN}-dbg += "${bindir}/.debug ${libdir}/weston/.debug ${prefix}/src"