Add recipe for trinity
[AGL/meta-agl.git] / meta-ivi-common / recipes-test / trinity / trinity_git.bb
1 SUMMARY = "a Linux System call fuzz teste."
2 DESCRIPTION = "Trinity, a Linux System call fuzz tester."
3 HOMEPAGE = "http://codemonkey.org.uk/projects/trinity/"
4 LICENSE = "GPLv2"
5 LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=96094d47cfbd2cc45eb46ce0fc423c04"
6
7 COMPATIBLE_HOST = "(x86_64|arm|aarch64).*-linux"
8
9 PV = "1.5"
10 SRCREV = "edc2e693e298e0372010a361354c4a79a3cd93f3"
11 SRC_URI = "git://github.com/kernelslacker/trinity.git;protocol=https;nobranch=1 \
12           "
13
14 S = "${WORKDIR}/git"
15
16 inherit useradd
17
18 USERADD_PACKAGES = "${PN}"
19 USERADD_PARAM_${PN} = "--system --create-home --shell /bin/sh ${PN} "
20
21 do_configure () {
22     ./configure.sh
23 }
24
25 # workaround random build failures
26 do_compile () {
27     ${MAKE}
28 }
29
30 do_install () {
31     oe_runmake install DESTDIR=${D}/usr
32     install -o ${PN} -d -m 0755 ${D}/${datadir}/${PN}
33     install -o ${PN} -m 0755 ${S}/scripts/test-all-syscalls-parallel.sh     ${D}/${datadir}/${PN}
34     install -o ${PN} -m 0755 ${S}/scripts/test-all-syscalls-sequentially.sh ${D}/${datadir}/${PN}
35     install -o ${PN} -m 0755 ${S}/scripts/test-multi.sh                     ${D}/${datadir}/${PN}
36     install -o ${PN} -m 0755 ${S}/scripts/test-vm.sh                        ${D}/${datadir}/${PN}
37 }
38
39 PACKAGES =+ "${PN}-example"
40
41 FILES_${PN} = "${bindir}/trinity"
42 FILES_${PN}-example = "${datadir}/${PN}"