Collapse all addition to the packagegroup for testing into one commit
[AGL/meta-agl.git] / meta-ivi-common / recipes-test / packagegroups / packagegroup-ivi-common-test.bb
1 SUMMARY = "Utilities for testing of AGL"
2 DESCRIPTION = "A set of common packages required by testing AGL for Quality Assurance"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PACKAGES = "\
9     packagegroup-ivi-common-test \
10     packagegroup-ivi-common-test-ltp \
11     "
12
13 ALLOW_EMPTY_${PN} = "1"
14
15 RDEPENDS_${PN} += "\
16     bc \
17     blobsallad \
18     dbench \
19     ebizzy \
20     ffsb \
21     interbench \
22     iozone3 \
23     iperf \
24     himeno \
25     nbench-byte \
26     netperf \
27     netpipe \
28     packagegroup-ivi-common-test-ltp \
29     rt-tests \
30     wayland-fits \
31     "
32
33
34 # Packages for shell commands which are required by LTP
35 #   readelf, logrotate, vsftpd, crontab, sar, arp, ftp,
36 #   host, rcp, rlogin, rsh, tcpdump, expect, iptables, dnsmasq,
37 #   pgrep
38 RDEPENDS_packagegroup-ivi-common-test-ltp += " \
39     initscripts-functions bind-utils binutils \
40     cronie dnsmasq expect inetutils-ftp inetutils-rsh \
41     iptables logrotate net-tools sysstat tcpdump vsftpd \
42     "