Mask netperf due to license.
[AGL/meta-agl.git] / meta-ivi-common / recipes-test / packagegroups / packagegroup-ivi-common-test.bb
1 SUMMARY = "Utilities for testing of AGL"
2 DESCRIPTION = "A set of common packages required by testing AGL for Quality Assurance"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PACKAGES = "\
9     packagegroup-ivi-common-test \
10     packagegroup-ivi-common-test-ltp \
11     "
12
13 ALLOW_EMPTY_${PN} = "1"
14
15 RDEPENDS_${PN} += "\
16     bc \
17     blobsallad \
18     dbench \
19     ebizzy \
20     ffsb \
21     interbench \
22     iozone3 \
23     iperf \
24     himeno \
25     ltp \
26     nbench-byte \
27     netpipe \
28     packagegroup-ivi-common-test-ltp \
29     rt-tests \
30     stress \
31     trinity \
32     wayland-fits \
33     "
34 # to be added, but needs LICENSE_FLAGS_WHITELIST="non-commercial"
35 #    netperf
36
37
38 # Packages for shell commands which are required by LTP
39 #   readelf, logrotate, vsftpd, crontab, sar, arp, ftp,
40 #   host, rcp, rlogin, rsh, tcpdump, expect, iptables, dnsmasq,
41 #   pgrep
42 RDEPENDS_packagegroup-ivi-common-test-ltp += " \
43     initscripts-functions bind-utils binutils \
44     cronie dnsmasq expect inetutils-ftp inetutils-rsh \
45     iptables logrotate net-tools sysstat tcpdump vsftpd \
46     "