674e93d441fe01818c21a3f5c99512c4db40fdb0
[AGL/meta-agl.git] / meta-ivi-common / recipes-test / packagegroups / packagegroup-ivi-common-test.bb
1 SUMMARY = "Utilities for testing of AGL"
2 DESCRIPTION = "A set of common packages required by testing AGL for Quality Assurance"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PACKAGES = "\
9     packagegroup-ivi-common-test \
10     packagegroup-ivi-common-test-ltp \
11     "
12
13 ALLOW_EMPTY_${PN} = "1"
14
15 RDEPENDS_${PN} += "\
16     bc \
17     blobsallad \
18     dbench \
19     ebizzy \
20     ffsb \
21     interbench \
22     iozone3 \
23     iperf \
24     himeno \
25     ltp \
26     nbench-byte \
27     netperf \
28     netpipe \
29     packagegroup-ivi-common-test-ltp \
30     rt-tests \
31     stress \
32     trinity \
33     wayland-fits \
34     "
35
36
37 # Packages for shell commands which are required by LTP
38 #   readelf, logrotate, vsftpd, crontab, sar, arp, ftp,
39 #   host, rcp, rlogin, rsh, tcpdump, expect, iptables, dnsmasq,
40 #   pgrep
41 RDEPENDS_packagegroup-ivi-common-test-ltp += " \
42     initscripts-functions bind-utils binutils \
43     cronie dnsmasq expect inetutils-ftp inetutils-rsh \
44     iptables logrotate net-tools sysstat tcpdump vsftpd \
45     "