3b7fe2a34db9aedd24490f97d0a94db2ca887b16
[AGL/meta-agl.git] / meta-ivi-common / recipes-test / packagegroups / packagegroup-ivi-common-test.bb
1 SUMMARY = "Utilities for testing of AGL"
2 DESCRIPTION = "A set of common packages required by testing AGL for Quality Assurance"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PACKAGES = "\
9     packagegroup-ivi-common-test \
10     packagegroup-ivi-common-test-ltp \
11     "
12
13 ALLOW_EMPTY_${PN} = "1"
14
15 RDEPENDS_${PN} += "\
16     bc \
17     blobsallad \
18     dbench \
19     ebizzy \
20     ffsb \
21     interbench \
22     iozone3 \
23     iperf \
24     himeno \
25     ltp \
26     nbench-byte \
27     netpipe \
28     packagegroup-ivi-common-test-ltp \
29     rt-tests \
30     stress \
31     trinity \
32     "
33 # to be added, but needs LICENSE_FLAGS_WHITELIST="non-commercial"
34 #    netperf
35 # wayland-fits is broken in jethro, https://www.mail-archive.com/openembedded-devel@lists.openembedded.org/msg46505.html
36 # http://errors.yoctoproject.org/Errors/Details/35141/
37 #     wayland-fits
38
39
40
41 # Packages for shell commands which are required by LTP
42 #   readelf, logrotate, vsftpd, crontab, sar, arp, ftp,
43 #   host, rcp, rlogin, rsh, tcpdump, expect, iptables, dnsmasq,
44 #   pgrep
45 RDEPENDS_packagegroup-ivi-common-test-ltp += " \
46     initscripts-functions bind-utils binutils \
47     cronie dnsmasq expect inetutils-ftp inetutils-rsh \
48     iptables logrotate net-tools sysstat tcpdump vsftpd \
49     "