Add recipe for netpipe package for QA
[AGL/meta-agl.git] / meta-ivi-common / recipes-test / netpipe / netpipe_3.7.2.bb
1 DESCRIPTION = "Network Protocol Independent Performance Evaluator"
2 LICENSE = "GPL-1.0"
3 URL = "http://bitspjoule.org/netpipe"
4
5 # PV from recipe filename
6 SRC_URI  = "http://bitspjoule.org/netpipe/code/NetPIPE-${PV}.tar.gz"
7 # change makefile to support env variables of bitbake
8 SRC_URI += "file://netpipe-makefile.patch"
9
10 SRC_URI[md5sum] = "653071f785404bb68f8aaeff89fb1f33"
11 SRC_URI[sha256sum] = "13dac884ff52951636f651c421f5ff4a853218a95aa28a4a852402ee385a2ab8"
12
13 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-1.0;md5=e9e36a9de734199567a4d769498f743d"
14
15 # bitbake expects ${PN}-${PV} which would be netpipe-3.7.2 but the tarball has:
16 S = "${WORKDIR}/NetPIPE-${PV}"
17
18 # added after 'make' as argument
19 EXTRA_OEMAKE = "tcp tcp6 memcpy"
20
21 do_install () {
22     install -d ${D}${bindir}
23     install -m 0755 NPtcp ${D}${bindir}
24     install -m 0755 NPtcp6 ${D}${bindir}
25     install -m 0755 NPmemcpy ${D}${bindir}
26 }