Add recipe for blobsallad package (JTA QA requirement)
[AGL/meta-agl.git] / meta-ivi-common / recipes-test / blobsallad / blobsallad_2006-11-14-23-57.bb
1 DESCRIPTION = ""
2 HOMEPAGE = "http://blobsallad.se/"
3 LICENSE = "CLOSED"
4 LIC_FILES_CHKSUM = ""
5
6 SRC_URI = " \
7     http://blobsallad.se/src/blobsallad-src-${PV}.tar.gz \
8     file://0001-Makefile.patch \
9     file://0002-auto.patch \
10     file://0003-printcleanup.patch \
11     file://0004-bs_main.c.patch"
12
13 SRC_URI[md5sum] = "a2e3342cbf0f3a4a9b110af2663bed36"
14 SRC_URI[sha256sum] = "cd6309df1929d3e6b7bce1dbecc751849aeaafe17c01e05fd2567dc4267faaa2"
15
16 DEPENDS = "cairo virtual/libsdl"
17
18 S = "${WORKDIR}/blobsallad-src"
19
20 do_configure () {
21         # Specify any needed configure commands here
22         :
23 }
24
25 do_compile () {
26         # You will almost certainly need to add additional arguments here
27         oe_runmake SDKROOT=${STAGING_DIR_HOST}
28 }
29
30 do_install () {
31         install -d ${D}${bindir}
32         install -m 0755 blobsallad ${D}${bindir}
33 }
34