Add support for GENIVI Diagnostic Log and Trace (DLT).
[AGL/meta-agl.git] / meta-ivi-common / recipes-extended / dlt-daemon / dlt-daemon_2.11.1.bb
1 SUMMARY = "Diagnostic Log and Trace"
2 DESCRIPTION = "This component provides a standardised log and trace interface, \
3 based on the standardised protocol specified in the AUTOSAR standard 4.0 DLT. \
4 This component can be used by GENIVI components and other applications as \
5 logging facility providing: \
6 - the DLT shared library \
7 - the DLT daemon, including startup scripts \
8 - the DLT daemon adaptors- the DLT client console utilities \
9 - the DLT test applications"
10 HOMEPAGE = "https://www.genivi.org/"
11 SECTION = "console/utils"
12 LICENSE = "MPLv2"
13 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=99ba60c3fad7eaf8c56bca6dd75cba09 \
14                     file://MPL.txt;md5=ccdb2761cef70c8b2612624c323f89dc"
15
16 DEPENDS = "dbus zlib"
17
18 # FIX ME
19 # This should be TAG = "v${PV}" but yocto doesn't support lightweight tags for now
20 # https://bugzilla.yoctoproject.org/show_bug.cgi?id=6881
21 TAG = "b8b3ea3a31f7deb681941a19878c82e7b7350ae7"
22 BRANCH = "v2.11.x"
23 SRC_URI = "git://git.projects.genivi.org/${PN}.git;branch=${BRANCH};tag=${TAG} \
24            file://0001-Fix-build-with-systemd-209.patch \
25            file://0002-Don-t-execute-processes-as-a-specific-user.patch \
26            file://0003-systemd-unit-type-should-be-in-lowercase-so-use-Type.patch \
27            file://0004-Modify-systemd-config-directory.patch"
28 S = "${WORKDIR}/git"
29
30 inherit gzipnative autotools gettext cmake systemd
31
32 PACKAGES += "${PN}-systemd"
33 SYSTEMD_PACKAGES = "${PN} ${PN}-systemd"
34 SYSTEMD_SERVICE_${PN} = "dlt-system.service dlt.service"
35 SYSTEMD_AUTO_ENABLE_${PN} = "enable"
36 SYSTEMD_SERVICE_${PN}-systemd = "dlt-example-user.service \
37     dlt-dbus.service \
38     dlt-adaptor-udp.service \
39     dlt-receive.service"
40 SYSTEMD_AUTO_ENABLE_${PN}-systemd = "disable"
41
42 EXTRA_OECMAKE = "-DWITH_SYSTEMD=ON"
43
44 FILES_${PN}-doc += "/usr/share/dlt-filetransfer"