AMB (automotive-message-broker): depend on python-misc/json
[AGL/meta-agl.git] / meta-ivi-common / recipes-automotive / automotive-message-broker / automotive-message-broker_git.bb
1 SUMMARY = "automotive message broker"
2 DESCRIPTION = "Automotive-message-broker abstracts the details of the network \
3 away from applications and provides a standard API for applications to easily \
4 get the required information"
5
6 HOMEPAGE = "https://github.com/otcshare/automotive-message-broker/wiki"
7 LICENSE = "LGPL-2.1"
8 LIC_FILES_CHKSUM = "file://COPYING;md5=b42382de5d854b9bb598acf2e8827de3"
9
10 inherit cmake systemd
11
12 PV = "0.12+git${SRCPV}"
13
14 # The 'gpsd' leads to a conflict between bluez4 and bluez5 because
15 # meta-openembedded/meta-oe/recipes-navigation/gpsd/gpsd_3.10.bb is able to
16 # select  bluez4 only instead AGL Distro choose bluez5 at changeset 4141.
17 # <https://gerrit.automotivelinux.org/gerrit/#/c/4141/>
18 #
19 # As temporary treatment, removing 'gpsd' from DEPENDS will let bitbake to build correctly.
20 #
21 #DEPENDS = "glib-2.0 util-linux sqlite3 qtbase boost json-c libtool gpsd"
22 DEPENDS = "glib-2.0 util-linux sqlite3 boost json-c libtool"
23 RDEPENDS_${PN} = "python-misc python-json"
24
25 SRC_URI = "git://github.com/otcshare/automotive-message-broker.git"
26 SRCREV = "ac3fe53327a13afc571efe079a31a0472ea285a3"
27
28 SRC_URI += "file://amb_allow_sessionbus.patch \
29             file://ambd.service \
30             "
31
32 SYSTEMD_PACKAGES = "${PN}"
33 SYSTEMD_SERVICE_${PN} = "ambd.service"
34
35 S = "${WORKDIR}/git"
36
37 # amb detects icecc in cmake and would override the 
38 # compiler selection of yocto. This breaks the build
39 # if icecc is installed on the host.
40 # -> Disable the detection in cmake.
41 EXTRA_OECMAKE += " -Denable_icecc=OFF"
42
43 do_install_append() {
44     mv ${D}/usr/include/amb/* ${D}/usr/include
45
46     install -d ${D}${systemd_unitdir}/system/
47     install -m 0644 ${WORKDIR}/ambd.service ${D}${systemd_unitdir}/system
48 }
49
50 FILES_${PN} += "${systemd_unitdir}/ambd.service"