Fix build issues while bitbake without meta-qt5
[AGL/meta-agl.git] / meta-ivi-common / recipes-automotive / automotive-message-broker / automotive-message-broker_git.bb
1 SUMMARY = "automotive message broker"
2 DESCRIPTION = "Automotive-message-broker abstracts the details of the network \
3 away from applications and provides a standard API for applications to easily \
4 get the required information"
5
6 HOMEPAGE = "https://github.com/otcshare/automotive-message-broker/wiki"
7 LICENSE = "LGPL-2.1"
8 LIC_FILES_CHKSUM = "file://COPYING;md5=b42382de5d854b9bb598acf2e8827de3"
9
10 inherit cmake systemd
11
12 # The 'gpsd' leads to a conflict between bluez4 and bluez5 because
13 # meta-openembedded/meta-oe/recipes-navigation/gpsd/gpsd_3.10.bb is able to
14 # select  bluez4 only instead AGL Distro choose bluez5 at changeset 4141.
15 # <https://gerrit.automotivelinux.org/gerrit/#/c/4141/>
16 #
17 # As temporary treatment, removing 'gpsd' from DEPENDS will let bitbake to build correctly.
18 #
19 #DEPENDS = "glib-2.0 util-linux sqlite3 qtbase boost json-c libtool gpsd"
20 DEPENDS = "glib-2.0 util-linux sqlite3 boost json-c libtool"
21 RDEPENDS_${PN} = "python-misc python-json"
22
23 PV = "0.14+git${SRCPV}"
24
25 SRC_URI = "git://github.com/CogentEmbedded/automotive-message-broker.git;protocol=https;branch=master"
26 SRCREV = "58569fac42bb8b6e1ad208caef5db8a51befc87f"
27
28 # The paches from 0001 to 0009 are from difference between 
29 # hash:58569fac42bb8b6e1ad208caef5db8a51befc87f(main branch) and
30 # hash:8f761e02172544212915c82b7e8dd8d4dd1281a6(dev_0.14_2)
31 SRC_URI += " \
32     file://0001-Improve-backward-compatibility-with-old-linaro-gcc.patch \
33     file://0002-Fix-library-versioning.patch \
34     file://0003-AmbSignalMapper-fix-can-interface-specification.patch \
35     file://0004-cansocketbcm-Fix-reading-of-frames-in-case-of-RX_TIM.patch \
36     file://0005-ambctl-remove-unnecessary-dependency-on-glib-introsp.patch \
37     file://0006-cangen-Implement-basic-handling-of-RX_TIMEOUT.patch \
38     file://0007-WORKAROUND-Allow-amb-qt-binding-to-work-in-case-of-m.patch \
39     file://0008-Add-simple-Qt-QML-example.patch \
40     file://0009-Add-Pressure-property-to-BrakeOperation.patch \
41     file://0001-Fix-build-issues-while-bitbake-without-meta-qt5-laye.patch \
42     file://ambd.service \
43     "
44
45 SYSTEMD_PACKAGES = "${PN}"
46 SYSTEMD_SERVICE_${PN} = "ambd.service"
47
48 S = "${WORKDIR}/git"
49
50 # amb detects icecc in cmake and would override the
51 # compiler selection of yocto. This breaks the build
52 # if icecc is installed on the host.
53 # -> Disable the detection in cmake.
54 EXTRA_OECMAKE += " -Denable_icecc=OFF"
55
56 do_install_append() {
57     mv ${D}/usr/include/amb/* ${D}/usr/include
58
59     install -d ${D}${systemd_unitdir}/system/
60     install -m 0644 ${WORKDIR}/ambd.service ${D}${systemd_unitdir}/system
61 }
62
63 FILES_${PN} += "${systemd_unitdir}/ambd.service"