fd195e90d0cb9f32d7a2efd1221f497c4a3df7d8
[AGL/meta-agl.git] / meta-agl / recipes-graphics / wayland / weston_1.5.0.bbappend
1 FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
2
3 SRC_URI_append = "\
4     file://weston.service \
5     file://weston.ini \
6     "
7
8 inherit systemd
9 DEPENDS_append = " systemd"
10
11 do_install_append() {
12     mkdir -p ${D}${systemd_unitdir}/system/
13     cp ${WORKDIR}/weston.service ${D}${systemd_unitdir}/system/
14     mkdir -p ${D}${systemd_unitdir}/system/multi-user.target.wants/
15     ln -sf /lib/systemd/system/weston.service ${D}/${systemd_unitdir}/system/multi-user.target.wants/weston.service
16
17     WESTON_INI_CONFIG=${sysconfdir}/xdg/weston
18     install -d ${D}${WESTON_INI_CONFIG}
19     install -m 0644 ${WORKDIR}/weston.ini ${D}${WESTON_INI_CONFIG}/weston.ini
20 }
21
22 FILES_${PN} += " \
23     ${systemd_unitdir}/system/* \
24     ${sysconfdir}/xdg/weston/weston.ini \
25     "