Make Weston desktop-shell panel configurable (backport)
[AGL/meta-agl.git] / meta-agl / recipes-graphics / wayland / weston_1.5.0.bbappend
1 FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
2
3 SRC_URI_append = "\
4     file://0001-desktop-shell-add-option-to-avoid-creating-the-panel.patch \
5     file://weston.service \
6     file://weston.ini \
7     "
8
9 inherit systemd
10 DEPENDS_append = " systemd"
11
12 do_install_append() {
13     mkdir -p ${D}${systemd_unitdir}/system/
14     cp ${WORKDIR}/weston.service ${D}${systemd_unitdir}/system/
15     mkdir -p ${D}${systemd_unitdir}/system/multi-user.target.wants/
16     ln -sf /lib/systemd/system/weston.service ${D}/${systemd_unitdir}/system/multi-user.target.wants/weston.service
17
18     WESTON_INI_CONFIG=${sysconfdir}/xdg/weston
19     install -d ${D}${WESTON_INI_CONFIG}
20     install -m 0644 ${WORKDIR}/weston.ini ${D}${WESTON_INI_CONFIG}/weston.ini
21 }
22
23 FILES_${PN} += " \
24     ${systemd_unitdir}/system/* \
25     ${sysconfdir}/xdg/weston/weston.ini \
26     "