Add touch_frame events to Weston 1.5.0
[AGL/meta-agl.git] / meta-agl / recipes-graphics / wayland / weston_1.5.0.bbappend
1 FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
2
3 SRC_URI_append = "\
4     file://0001-desktop-shell-add-option-to-avoid-creating-the-panel.patch \
5     file://0001-Adapt-changes-made-in-libinput-src-evdev.c-for-touch.patch \
6     file://weston.service \
7     file://weston.ini \
8     "
9
10 inherit systemd
11 DEPENDS_append = " systemd"
12
13 do_install_append() {
14     mkdir -p ${D}${systemd_unitdir}/system/
15     cp ${WORKDIR}/weston.service ${D}${systemd_unitdir}/system/
16     mkdir -p ${D}${systemd_unitdir}/system/multi-user.target.wants/
17     ln -sf /lib/systemd/system/weston.service ${D}/${systemd_unitdir}/system/multi-user.target.wants/weston.service
18
19     WESTON_INI_CONFIG=${sysconfdir}/xdg/weston
20     install -d ${D}${WESTON_INI_CONFIG}
21     install -m 0644 ${WORKDIR}/weston.ini ${D}${WESTON_INI_CONFIG}/weston.ini
22 }
23
24 FILES_${PN} += " \
25     ${systemd_unitdir}/system/* \
26     ${sysconfdir}/xdg/weston/weston.ini \
27     "