Upgrade to Wayland/Weston 1.9.0
[AGL/meta-agl.git] / meta-agl / recipes-graphics / wayland / wayland_1.9.0.bb
1 SUMMARY = "Wayland, a protocol between a compositor and clients"
2 DESCRIPTION = "Wayland is a protocol for a compositor to talk to its clients \
3 as well as a C library implementation of that protocol. The compositor can be \
4 a standalone display server running on Linux kernel modesetting and evdev \
5 input devices, an X application, or a wayland client itself. The clients can \
6 be traditional applications, X servers (rootless or fullscreen) or other \
7 display servers."
8 HOMEPAGE = "http://wayland.freedesktop.org"
9 LICENSE = "MIT"
10 LIC_FILES_CHKSUM = "file://COPYING;md5=b31d8f53b6aaf2b4985d7dd7810a70d1 \
11                     file://src/wayland-server.c;endline=24;md5=b8e046164a766bb1ede8ba38e9dcd7ce"
12
13 SRC_URI = "http://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz"
14 SRC_URI[md5sum] = "5e141b3f2a7005d6c89d6f233c87c317"
15 SRC_URI[sha256sum] = "9c8770720aa0034479735f58a4dc4ca9b172ecfede28f5134312e135b7301efa"
16
17 EXTRA_OECONF_class-native = "--disable-documentation"
18
19 inherit autotools pkgconfig
20
21 BBCLASSEXTEND = "native nativesdk"
22
23 DEPENDS = "expat libffi wayland-native"
24
25 EXTRA_OECONF = "--disable-documentation --with-host-scanner"
26
27 # Wayland installs a M4 macro for other projects to use, which uses the target
28 # pkg-config to find files.  Replace pkg-config with pkg-config-native.
29 do_install_append_class-native() {
30   sed -e 's,PKG_CHECK_MODULES(.*),,g' \
31       -e 's,$PKG_CONFIG,pkg-config-native,g' \
32       -i ${D}/${datadir}/aclocal/wayland-scanner.m4
33 }
34
35 sysroot_stage_all_append_class-target () {
36         rm ${SYSROOT_DESTDIR}/${datadir}/aclocal/wayland-scanner.m4
37         cp ${STAGING_DATADIR_NATIVE}/aclocal/wayland-scanner.m4 ${SYSROOT_DESTDIR}/${datadir}/aclocal/
38 }
39
40 FILES_${PN} = "${libdir}/*${SOLIBS}"
41 FILES_${PN}-dev += "${bindir} ${datadir}/wayland"