Provide automatic DHCP configuration for Ethernet adapters
[AGL/meta-agl.git] / meta-agl / recipes-devtools / libgee / libgee-0.8_0.16.1.bb
1 DESCRIPTION = "libgee is a collection library providing GObject-based interfaces \
2 and classes for commonly used data structures."
3 HOMEPAGE = "http://live.gnome.org/Libgee"
4 SECTION = "libs"
5 DEPENDS = "glib-2.0 gobject-introspection-stub"
6
7 BBCLASSEXTEND = "native"
8 LICENSE = "LGPLv2.1"
9 LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
10
11 PE = "1"
12
13 inherit autotools vala pkgconfig
14 do_configure_prepend() {
15     MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4"
16     for i in ${MACROS}; do
17         rm -f m4/$i
18     done
19 }
20
21 SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}"
22 SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/libgee/${SHRT_VER}/libgee-${PV}.tar.xz"
23 SRC_URI[md5sum] = "d30cf203784431b0fdc3216b1acd999c"
24 SRC_URI[sha256sum] = "d95f8ea8e78f843c71b1958fa2fb445e4a325e4821ec23d0d5108d8170e564a5"
25
26 S = "${WORKDIR}/libgee-${PV}"