Add systemd configuration to launch psplash
[AGL/meta-agl.git] / meta-agl / recipes-core / psplash / psplash_git.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3 SRC_URI += "file://psplash-colors.h \
4             file://psplash-start.service \
5             file://psplash-quit.service \
6             "
7
8 SPLASH_IMAGES="file://psplash-poky-img.h;outsuffix=default"
9
10 inherit systemd
11
12 SYSTEMD_PACKAGES = "${@base_contains('DISTRO_FEATURES', 'systemd', '${PN}', '', d)}"
13 SYSTEMD_SERVICE_${PN} = "${@base_contains('DISTRO_FEATURES', 'systemd', 'psplash-start.service psplash-quit.service', '', d)}"
14
15 do_configure_append () {
16         cd ${S}
17         cp ../psplash-colors.h ./
18 }
19
20 do_install_append () {
21     if ${@base_contains('DISTRO_FEATURES','systemd','true','false',d)}; then
22         install -d ${D}${systemd_unitdir}/system
23         install -m 644 ${WORKDIR}/*.service ${D}/${systemd_unitdir}/system
24     fi
25 }