The starting point of layers for AGL Distribution v1.0
[AGL/meta-agl.git] / meta-agl / recipes-core / packagegroups / packagegroup-core-boot-agl.bb
1 #
2 # Copyright (C) 2007 OpenedHand Ltd.
3 #
4 # derived from oe-core: meta/recipes-core/packagegroups/packagegroup-core-boot.bb
5
6 SUMMARY = "Minimal boot requirements"
7 DESCRIPTION = "The minimal set of packages required to boot the system"
8 LICENSE = "MIT"
9 PR = "r17"
10
11 PACKAGE_ARCH = "${MACHINE_ARCH}"
12
13 inherit packagegroup
14
15 #
16 # Set by the machine configuration with packages essential for device bootup
17 #
18 MACHINE_ESSENTIAL_EXTRA_RDEPENDS ?= ""
19 MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS ?= ""
20
21 # Distro can override the following VIRTUAL-RUNTIME providers:
22 VIRTUAL-RUNTIME_dev_manager ?= "udev"
23 VIRTUAL-RUNTIME_login_manager ?= "busybox"
24 VIRTUAL-RUNTIME_init_manager ?= "sysvinit"
25 VIRTUAL-RUNTIME_initscripts ?= "initscripts"
26 VIRTUAL-RUNTIME_keymaps ?= "keymaps"
27
28 SYSVINIT_SCRIPTS = "${@bb.utils.contains('MACHINE_FEATURES', 'rtc', 'busybox-hwclock', '', d)} \
29                     modutils-initscripts \
30                     init-ifupdown \
31                     ${VIRTUAL-RUNTIME_initscripts} \
32                    "
33
34 RDEPENDS_${PN} = "\
35     base-files \
36     base-passwd \
37     busybox \
38     ${@bb.utils.contains("DISTRO_FEATURES", "sysvinit", "${SYSVINIT_SCRIPTS}", "", d)} \
39     ${@bb.utils.contains("MACHINE_FEATURES", "keyboard", "${VIRTUAL-RUNTIME_keymaps}", "", d)} \
40     netbase \
41     ${VIRTUAL-RUNTIME_login_manager} \
42     ${VIRTUAL-RUNTIME_init_manager} \
43     ${VIRTUAL-RUNTIME_dev_manager} \
44     ${VIRTUAL-RUNTIME_update-alternatives} \
45     ${MACHINE_ESSENTIAL_EXTRA_RDEPENDS}"
46
47 RRECOMMENDS_${PN} = "\
48     ${MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS}"
49