rygel: add systemd service
[AGL/meta-agl.git] / meta-agl / recipes-connectivity / rygel / rygel_%.bbappend
1 # Disable everything but the media-export plugin, add the lms plugin
2 PACKAGECONFIG = "media-export lms"
3 PACKAGECONFIG[lms] = "--enable-lms-plugin,--disable-lms-plugin,sqlite3"
4
5 # LightMediaScanner plugin patches
6 SRC_URI += "file://0001-Add-LightMediaScanner-plugin.patch \
7             file://0002-lms-add-C-source-files.patch \
8             file://rygel.service \
9             "
10
11 inherit systemd
12
13 SYSTEMD_PACKAGES = "${PN}"
14 SYSTEMD_SERVICE_${PN} = ""
15 SYSTEMD_SERVICE_${PN} += "rygel.service"
16
17 do_install_append() {
18        # Install rygel systemd service
19        if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
20               install -p -D ${WORKDIR}/rygel.service ${D}${systemd_unitdir}/system/rygel.service
21        fi
22 }